浙大数据结构08-图8 How Long Does It Take_拓扑排序

Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.

 

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N−1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i]E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i] the lasting time of the activity. The numbers in a line are separated by a space.

Output Specification:

For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output "Impossible".

Sample Input 1:

9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4

结尾无空行

Sample Output 1:

18

结尾无空行

Sample Input 2:

4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5

Sample Output 2:

Impossible

 

#include <bits/stdc++.h>
#define x first
#define y second
using namespace std;
typedef long long ll;
int main()
{
//    system("chcp 65001");
    cin.tie(0);
    cout.tie(0);
//    freopen("C:/Users/zhaochen/Desktop/input.txt", "r", stdin);
    int N, M;
    cin >> N >> M;
    vector<int>g[128];
    int len[128][128] = {0};
    int indegree[128] = {0};
    for(int i = 0; i < M; i++)
    {
        int a, b;
        cin >> a >> b >> len[a][b];
        g[a].push_back(b);
        indegree[b]++;  // 入度+1
    }
    queue<int>q;
    for(int i = 0; i < N; i++)
    {
        if(indegree[i] == 0)  // 将所有入度为0的顶点入队
        {
            q.push(i);
        }
    }
    int cnt = 0, ans = 0;
    int earliest_finish[128] = {0};  // 各任务最早完成的时间
    while(!q.empty())
    {
        int V = q.front();           // 弹出一个入度为0的顶点
        q.pop();
        cnt++;
        for(int i = 0; i < g[V].size(); i++)
        {
            int t = g[V][i];         // 对于V的每个邻接点
            indegree[t]--;           // 入度-1
            earliest_finish[t] = max(earliest_finish[t], earliest_finish[V] + len[V][t]);
            ans = max(ans, earliest_finish[t]);
            if(indegree[t] == 0)     // 若删除V使得该顶点入度为0
            {
                q.push(t);           // 则该顶点入队
            }
        }
    }
    if(cnt != N)    // 说明图中有回路
    {
        cout << "Impossible";
    }
    else
    {
        cout << ans;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值