PTA-1012

The Best Rank

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:
1 C
1 M
1 E
1 A
3 A
N/A

题目大意
求每个学生在所有科目(三门学科加一个平均分)中的最佳排名及对应科目。如果一个学生的最佳排名存在多个,则根据A > C > M > E的优先级定最佳科目。

解答:

1.本题要计算每个学科学生对应的排名,采用的是先用sort算法先计算学科排名(通过一个compareIndex来用同一个仿函数实现不同学科),再根据是否同成绩给出排名
2.本题采用学号映射id的方法来实现搜索成绩
3.注意结构体数组的定义,前面不能加typedef,后面直接加变量名就是直接定义一个结构体,加数组变量就是直接定义一个结构体数组。

#define  _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
struct Student {
    int grade[4];
    int rank[4];
    int id;
}students[2000];
int id[1000000];
int CompareIndex = -1;
//从大到小排序的仿函数
bool cmp(Student a, Student b) { return a.grade[CompareIndex] > b.grade[CompareIndex]; }

int main() {
    int m, n;
    scanf("%d %d", &m, &n);

    struct Student* stu;//定义一个临时变量,保存每一轮操作的
    //成绩初始化
    for (int i = 0; i < m; i++) {
        stu = &students[i];
        scanf("%d %d %d %d", &(stu->id), &(stu->grade[1]), &(stu->grade[2]), &(stu->grade[3]));
        stu->grade[0] = (stu->grade[1] + stu->grade[2] + stu->grade[3]) / 3;
    }
    for (int i = 0; i < 4; i++) {
        //按当前科目重新排序 CompareIndex是比较的科目序号
        CompareIndex = i;
        sort(students, students + m, cmp);

        //先给当前科目排序,再按照排序后的当前科目排名给rank[i]赋值
        for (int j = 0; j < m; j++)
            if (students[j].grade[i] == students[j - 1].grade[i])
                students[j].rank[i] = students[j-1].rank[i];//成绩相同共享排名
            else students[j].rank[i] = j + 1;
    }
    //初始化存放已经有了的学生的id,-1代表此学生不存在
    fill(id, id + 1000000, -1);
    //初始化映射数组
    for (int i = 0; i < m; i++) {
        id[students[i].id] = i;
    }
    int search, index;
    int top = 2001, topJ = 0;
    char subjects[] = { 'A','C','M','E' };
    for (int i = 0; i < n; i++) {
        scanf("%d", &search);
        index = id[search];  //学号映射id
        if (index < 0) printf("N/A\n");
        else {  //维护一个最优排名
            top = 2001;topJ = 0;//输出完一次要恢复初值
            for (int j = 0; j < 4; j++)
                if (students[index].rank[j] < top) {
                    top = students[index].rank[j];
                    topJ = j;
                }
            printf("%d %c\n", top, subjects[topJ]);
        }
    }
    return 0;
}
#include<iostream>
#include<algorithm>
using namespace std;
struct Student{
    int id;
    int grade[4];
    int rank[4];
}students[2001];

int CompareIndex=-1,id[1000000];
bool cmp(Student a,Student b){return a.grade[CompareIndex]>b.grade[CompareIndex];}

int main(){
    int m,n;
    cin>>m>>n;
    //学生成绩初始化
    for(int i=0;i<m;i++){
        struct Student *stu = &students[i];
        cin>>stu->id>>stu->grade[1]>>stu->grade[2]>>stu->grade[3];
        stu->grade[0]=(stu->grade[1]+stu->grade[2]+stu->grade[3])/3;
    }
    //分科目排名,i代表科目
    for(int i=0;i<4;i++){
        CompareIndex=i;
        sort(students,students+m,cmp);
        for(int j=0;j<m;j++)
            if(students[j].grade[i]==students[j-1].grade[i]) students[j].rank[i]=students[j-1].rank[i];
        else students[j].rank[i]=j+1;
    }
    
    fill(id,id+1000000,-1);
    //初始化映射关系
    int search=0,top=2001,topJ=0;//top维护的是最优排名,top维护的是最优排名对应的科目
    char Search[4]={'A','C','M','E'};
    for(int i=0;i<m;i++) id[students[i].id]=i;
    for(int i=0;i<n;i++){
        cin>>search;
        int index=id[search];//通过映射关系找到id对应序号
        if(index<0) cout<<"N/A"<<endl;
        else{
            top=2001;topJ=0;
            for(int j=0;j<4;j++){
                //对于维护对象有多个的情况,每轮维护结束需要将维护的变量回归初始值
                if(students[index].rank[j]<top){
                    top=students[index].rank[j];
                    topJ=j;
                }
            }
            cout<<top<<" "<<Search[topJ]<<endl;
        }
    }
    
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值