Reversed 3-Digit-Number

Your program reads a positive 3-digit-number in and prints the digits in reversed order. There should not be any leading zeros when the number has tailing zeros. For example, the output should be 7 for the number 7000.

Input Format:

A postive 3-digit-number.

Output Format:

A reversed number.

Sample Input:

123

Sample Output:

321

//题目就是把一个数逆序输出,需要注意的是,例如7000逆序输出为7,而不是0007,但不能单纯的不输出0,例如105逆序输出为501; 

 

 import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
                int n = in.nextInt();
        int f=0;
           while(n!=0)
        {
         
         if(n%10!=0||f==1){System.out.print(n%10);f=1;}
  //这个判断解决了需要注意的点。我们要保证在没有遇到非零数之前的0都是不输出的,如果遇到非零数,就把f标记为1,那么后面出现的0都要输出。
         n/=10;
         }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

星河欲转。

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值