7-10 树的遍历 (25 分)

7-10 树的遍历 (25 分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

思路(递归,链表存储)

在这里插入图片描述

在这里插入图片描述

在这里插入图片描述

AC代码

#include <iostream>
using namespace std;

int post[31], inorder[31];
int flag = 1;
typedef struct node
{
	int data;
	node* lchild;
	node* rchild;
}*TNode;
TNode Create(int root, int start, int end)
{
	TNode T;
	int i;
	if (end < start)return NULL;
	T = (TNode)malloc(sizeof(struct node));
	T->data = post[root];
	for (i = start; post[root] != inorder[i]; i++);
	T->lchild = Create(root - 1 - (end - i), start, i - 1);
	T->rchild = Create(root - 1, i + 1, end);
	return T;
}
void Level(TNode T)
{
	int front = -1, rear = 0;
	TNode queue[31];
	if (!T)return;
	queue[rear] = T;//从尾部插入
	while (rear > front)
	{
        if(flag)
        {
            cout << queue[++front]->data;
            flag=0;
        }
        else cout << " " << queue[++front]->data;
		if (queue[front]->lchild)queue[++rear] = queue[front]->lchild;
		if (queue[front]->rchild)queue[++rear] = queue[front]->rchild;
	}
}
int main()
{
	int i, N;
	TNode T;
	cin >> N;
	for (i = 0; i < N; i++)
		cin >> post[i];
	for (i = 0; i < N; i++)
		cin >> inorder[i];
	T = Create(N - 1, 0, N - 1);
	Level(T);
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值