【BFS】HUD-Asteroids

HUD 1240 Asteroids!

Asteroids!

You’re in space.
You want to get home.
There are asteroids.
You don’t want to hit them.
Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

Start line - A single line, “START N”, where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

‘O’ - (the letter “oh”) Empty space

‘X’ - (upper-case) Asteroid present

Starting Position - A single line, “A B C”, denoting the <A,B,C> coordinates of your craft’s starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, “D E F”, denoting the <D,E,F> coordinates of your target’s position. The coordinate values will be integers separated by individual spaces.

End line - A single line, “END”

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.

Output
For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format “X Y”, where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be “NO ROUTE” instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.

Sample Input

START 1
O
0 0 0
0 0 0
END
START 3
XXX
XXX
XXX
OOO
OOO
OOO
XXX
XXX
XXX
0 0 1
2 2 1
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END

Sample Output

1 0
3 4
NO ROUTE
题目大意
  • 三维的迷宫问题,给你一个地图,里面有空地和障碍物,让你得出从一个地方到另一个地方的最小步数,没有什么多说的
思路
  • BFS
  • 这道题就是BFS的模板题,但难点在于处理输入
  • 注意从二维的迷宫拓展到三维的迷宫就行了
  • 特别注意坐标的对应
代码如下
#include <iostream>
#include <queue>
using namespace std;

struct pos {
    int x, y, z;
    int step;
    pos(int xx = 0, int yy = 0, int zz = 0, int sp = 0)
        : x(xx), y(yy), z(zz), step(sp) {}
} top, tmp, pstart, pend;

const int MAXN = 11;
const int to[6][3] = {{1, 0, 0},  {-1, 0, 0}, {0, 1, 0},
                      {0, -1, 0}, {0, 0, 1},  {0, 0, -1}};

char mp[MAXN][MAXN][MAXN];
bool vis[MAXN][MAXN][MAXN];
queue<pos> q;
int i, j, k;
int n;
char op[10];

void bfs(const pos& p1, const pos& p2) {
    //两个坐标相等的话就直接输出0了
    if (p1.x == p2.x && p1.y == p2.y && p1.z == p2.z) {
        printf("%d 0\n", n);
        return;
    }
    //清空一下队列
    while (!q.empty()) q.pop();
    // BFS模板
    q.push(p1);
    vis[p1.z][p1.x][p1.y] = true;
    while (!q.empty()) {
        top = q.front();
        q.pop();
        for (i = 0; i < 6; i++) {
            tmp.x = top.x + to[i][0];
            tmp.y = top.y + to[i][1];
            tmp.z = top.z + to[i][2];
            tmp.step = top.step + 1;
            if (tmp.x >= n || tmp.x < 0 || tmp.y >= n || tmp.y < 0 ||
                tmp.z >= n || tmp.z < 0)
                continue;
            if (vis[tmp.z][tmp.x][tmp.y] || mp[tmp.z][tmp.x][tmp.y] == 'X')
                continue;
            if (tmp.x == p2.x && tmp.y == p2.y && tmp.z == p2.z) {
                printf("%d %d\n", n, tmp.step);
                return;
            }
            q.push(tmp);
            vis[tmp.z][tmp.x][tmp.y] = true;
        }
    }
    puts("NO ROUTE");
}

void solve() {
    //这道题的难点是卡输入,这种输入方式是可行的
    while (scanf("%s", op) != EOF) {
        scanf("%d", &n);
        for (i = 0; i < n; i++) {
            for (j = 0; j < n; j++) {
                for (k = 0; k < n; k++) {
                    scanf(" %c", &mp[i][j][k]);
                    vis[i][j][k] = false;  //顺便初始化
                }
            }
        }
        scanf("%d%d%d%d%d%d", &pstart.x, &pstart.y, &pstart.z, &pend.x, &pend.y,
              &pend.z);
        bfs(pstart, pend);
        scanf("%s", op);
    }
}

int main(void) {
    solve();
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

木又可可

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值