C++中有函数strrev,功能是对字符串实现反转,但是要记住,strrev函数只对字符数组有效,对string类型是无效的。
如下题所示:
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
Output
For each test case, you should output the text which is processed.
Sample Input
3
olleh !dlrow
m’I morf .udh
I ekil .mca
Sample Output
hello world!
I’m from hdu.
I like acm.
Hint
Remember to use getchar() to read ‘\n’ after the interger T, then you may use gets() to read a line and process it.
源代码如下:
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
char str[1005],temp[1005];
int t;
int j=0,len=0;
cin>>t;
getchar();
while(t--)
{
gets(str);
len=strlen(str);
for(int i=0;i<=len;i++)
{
if(str[i]==' '||str[i]=='\0')
{
strrev(temp);
if(str[i]==' ')
cout<<temp<<" ";
else
cout<<temp;
j=0;
}
else
temp[j++]=str[i];
temp[j]='\0';
}
cout<<endl;
}
return 0;
}