题目
输入样例:
5 5 3
0 2
0 4
1 3
输出样例:
12
思路
重点:设置一个数组判断该行列是否已经被BOSS用技能打过
ac代码:
#include<iostream>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<iomanip>
using namespace std;
int main()
{
int n,m,q;
cin>>n>>m>>q;
int hang=0,lie=0;
int t,c;
int a[101010][10];
while(q--){
cin>>t>>c;
if(a[c][t]==1)//注意 有可能有重复的
{
continue;
}
a[c][t]=1;
if(t==0)//hang
hang++;
else
lie++;
}
cout<<(n-hang)*(m-lie);
return 0;
}