PTA 1044 火星数字 (20 分) C++实现

1044 火星数字 (20 分)

火星人是以 13 进制计数的:

地球人的 0 被火星人称为 tret。
地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam
结尾无空行

输出样例:

hel mar
may
115
13
结尾无空行

解题思路:

本题有许多注意的地方:
①如果输入为数字:
当这个数字为13的倍数时,比如:26,转换为火星数字应为20,按道理而言,答案应为hel tret,但是这里不应该出现tret,因为这个tret只适用于这个所输入的数字本身为0才输出tret,其余情况不会含有tret,因此答案应为hel
②当输入为火星数字时:
常规处理即可,但是有技巧

代码示例:

#define _CRT_SECURE_NO_DEPRECATE
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <vector>
#include <string>
#include <cmath>
#include <numeric>
#include <deque>
#include <map>

using namespace std;

int main()
{
	int n;
	cin >> n;
	getchar();
	
	//未进位的火星文
	vector<string> low = { "tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec" };
	//已进位的火星文
	vector<string> hight = { "","tam", "hel", "maa", "huh", "tou", "kes","hei", "elo", "syy", "lok", "mer", "jou" };

	while (n--)
	{
		string s;
		getline(cin, s);
		
		if (s[0] >= '0' && s[0] <= '9')
		{
			int num = stoi(s);
			if (num > 13 && num % 13 != 0) //大于13且不为13的倍数时
			{
				cout << hight[num / 13] << " " << low[num % 13] << endl;
			}
			else if(num > 0 && num % 13 == 0)//为13的倍数却不为0时,不输出末尾的tret
			{
				cout << hight[num / 13] << endl;
			}
			else //包含0却小于13时
			{
				cout << low[num] << endl;
			}
			
		}
		else
		{
			int ans = 0;
			if (s.length() > 3)
			{
				string s1, s2;
				s1 = s.substr(0, 3); //取字符串s的某个范围的字符串
				s2 = s.substr(4);  //取字符串s下标为4及其以后的字符串

				for (int i = 0; i < 13; i++)
				{
					if (s1 == hight[i])
					{
						ans += i * 13;
					}

					if (s2 == low[i])
					{
						ans += i;
					}

				}
			}
			else
			{
				for (int i = 0; i < 13; i++)
				{
					if (s == hight[i])
					{
						ans += i * 13;
					}
					
					if(s == low[i])
					{
						ans += i;
					}
				}
			}
			cout << ans << endl;

		}
	}
}

运行结果:

在这里插入图片描述

  • 5
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Crazy.宥思

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值