题目描述
从键盘输入一个字符,判断该字符是否大写字母、小写字母、数字字符或其他字符。分别输出对应的提示信息。
输入
输入一个字符。
输出
如果该字符是大写字母,则输出“upper”;若是小写字母,则输出“lower”;若是数字字符,则输出“digit”;若是其他字符,则输出“other”。(输出不含双引号)。
样例输入
E
样例输出
upper
#include<stdio.h>
#include<ctype.h> //字符处理函数
int main(){
char ch;
scanf("%c",&ch);
if(isupper(ch))
printf("upper\n");
else if(islower(ch))
printf("lower\n");
else if(isdigit(ch))
printf("digit\n");
else
printf("other\n");
return 0;
}