HDU----1097A hard puzzle

问题描述

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b’s the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

输入格式

There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

输出格式

For each test case, you should output the a^b’s last digit number.

输入样例

7 66
8 800

输出样例

9
6

代码如下

#include<stdio.h>
int f(int a,int b)
{
	int t=1;
	a %= 10;
	//快速幂取模
	//(a * b) % p = (a%p)*(b%p) %p
	while(b!=0)
	{
		if(b&1)
		{
			t=t*a%10;
		}	
		b/=2;//  b >>= 2
	    a=a*a%10;//余最后一位		
	}
	return t;
}
int main(void)
{
	int a,b;
	while(scanf("%d %d",&a,&b)!=EOF)
	{
		printf("%d\n",f(a,b));
	}
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值