01-复杂度2 Maximum Subsequence Sum (25 分)

01-复杂度2 Maximum Subsequence Sum (25 分)

21-6-30

Given a sequence of K integers { N​1​​, N​2​​, …, N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

#include<stdio.h>
int list[10010];
int main(){
    int n;
    scanf("%d",&n);
    int i, j;
    for(i = 0;i < n;i ++){
        scanf("%d",&list[i]);
    }
    int max, head, tail, temp, tidx;
    max = head = tail = temp = tidx = 0; 
    for(i = 0;i < n;i ++){
        temp += list[i];
        if(max < temp){
            max = temp;
            head = tidx;
            tail = i;
        }else if(temp < 0){
            temp = 0;
            tidx = i + 1;
        }
    }
    if(max < 0){
        printf("%d %d %d",0, list[0], list[n - 1]);
    }else if(max == 0){
        for(i = 0;i < n;i ++){
            if(list[i] == 0){
                break;
            }
        }
        if(i < n){
             printf("%d %d %d",0, 0, 0);
        }else{
             printf("%d %d %d",0, list[0], list[n - 1]);
        }
    }
    else{
        printf("%d %d %d",max, list[head],list[tail]);
    }
    return 0;
}

0 sample换1个数字。有正负,负数开头结尾,有并列最大和
答案正确
13 4 ms 188 KB
1 最大和序列中有负数
答案正确
2 4 ms 188 KB
2 并列和对应相同i但是不同j,即尾是0
答案正确
2 5 ms 192 KB
3 1个正数
答案正确
2 16 ms 192 KB
4 全是负数
答案正确
2 10 ms 196 KB
5 负数和0
答案正确
2 4 ms 188 KB
6 最大和前面有一段是0
答案正确
1 9 ms 188 KB

心得:
1、很多时候不用重写,只要花点心思在改动上,线性处理还算快
2、标记开头和结尾,首先是在每次更改最大值时对应配套改动,所以在此之前要确定前后的相对位置,尾的位置好确定,是赋值当时的标,头的值应是前一次计数结尾的后一个标,这里的结尾不只指上一段最大和的结束,也可以是不满足条件的(比如负值和零)
3、要求输出下标较小的结果,也不需特殊处理,因为只要 if(max < temp),只有更大的值才会更新,而相等的值并不会引起更新。
4、通过测试点,有全是负数,负数和零相间,先全零后负,注意输出条件的判断

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值