POJ 1013 Counterfeit Dollar

POJ 1013 Counterfeit Dollar

Description
Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input
The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A–L. Information on a weighing will be given by two strings of letters and then one of the words up'',down’’, or ``even’’. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output
For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input
1
ABCD EFGH even
ABCI EFJK up
ABIJ EFGH even
Sample Output
K is the counterfeit coin and it is light.

思路
分别判断是重了还是轻了。每一次天平不平衡,肯定是由于其中一边有假硬币,利用枚举法带入进行判断,天平轻或重的一端是否应该有该硬币。

注意

  1. 不知道假币是重是轻
  2. 一次不一定只称量4个
  3. 多组测试数据 每次输出换行
  4. 只能称取3次且都能找到假币

代码

#include<iostream>
#include<cstring>
using namespace std;

string left[3],right[3],result[3];	//定义成全局变量方便调用 													

bool fakelight(char c) 	//判断是否是轻的假币  是就返回真 																

{
	for(int i=0;i<3;i++)
	{
		switch(result[i][0])
		{
			case'e':     //只需判断首字母																	
				if(::left[i].find(c)!=string::npos||::right[i].find(c)!=string::npos)	 
					return false;	//重量相等肯定都是真的  c不能在左右两边 
				break;																	
			case'u':    //如果c是轻的假币,则c一定在右边,不在左边。
				if(::left[i].find(c)!=string::npos||::right[i].find(c)==string::npos)	
					return false;	
				break;			//如果不是这种情况就返回false 														 
			case'd':
				if(::left[i].find(c)==string::npos||::right[i].find(c)!=string::npos)
					return false;
				break;
		}
	}
	return true;
}

bool fakeheavy(char c) 			//判断是否为重的假币  同理														 
{
	for(int i=0;i<3;i++)
	{
		switch(result[i][0])
		{
			case'e':
				if(::left[i].find(c)!=string::npos||::right[i].find(c)!=string::npos)
					return false;
				break;
			case'u':
				if(::left[i].find(c)==string::npos||::right[i].find(c)!=string::npos)
					return false;
				break;
			case'd':
				if(::left[i].find(c)!=string::npos||::right[i].find(c)==string::npos)
					return false;
				break;
		}
	}
	return true;
}
 
int main()
{
	int n;
	cin>>n;
	while(n--)
	{	
		for(int i=0;i<3;i++)	
			cin>>::left[i]>>::right[i]>>result[i];		
			//为什么要加::   std内好像有定义的right和left  不加::会报错 指向不明确 
		for(char i='A';i<='L';i++)
		{
			if(fakelight(i))
			{	
				cout<<i<<" is the counterfeit coin and it is light."<<endl;
				break;
			}
			if(fakeheavy(i))
			{
				cout<<i<<" is the counterfeit coin and it is heavy."<<endl;
				break;
			}		
		}	
	}
	return 0;
}
//补充:
//find()是string类的成员函数,可以查找str中是否包含字符串c,若包含则返回其位置,否则返回string::nops 
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值