POJ 1011 Sticks(dfs 剪枝)

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5

思路

dfs+剪枝
不剪枝会超时
具体看代码

代码

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;

int l[80],vis[80];							//l长度 vis标记棍是否用过 
int n,sum,num;								//n棍的总数 sum棍的长度 num接成棍的数量 

bool dfs(int cnt,int now,int pos,int len)	//cnt已拼成的棍  now此次拼接的现有长度 
{											//pos指针,此次遍历到的位置 len拼接完成后一根棍的长度 
	if(cnt==num)
		return true;						//拼完 返回 
	for(int i=pos+1;i<=n;i++)
	{
		if(vis[i])							//用过 
			continue;
		if(now+l[i]==len)					//刚好拼好 
		{
			vis[i]=1;						//标记 
			if(dfs(cnt+1,0,0,len))			//判断下一根是否可拼好 
				return true;
			vis[i]=0;						//拼接失败,原标记清除 
			return false;
		}
		else if(now+l[i]>len)				//大于肯定不行 
			continue;
		else
		{
			vis[i]=1;						//标记 
			if(dfs(cnt,now+l[i],i,len))		//长度不够,找下一部分
				return true;				//剪枝  从上次遍历位置后面继续 
			vis[i]=false;
			if(now==0)
				return false;				//剪枝  如果现有长度为零且第一根棍用不了的话就肯定不行 
			while(l[i]=l[i+1])				//因为每一根棍子都要被用到,长度为0的时候应该是随便用	
				i++;						//剪枝   因为是排好序的,所以下一段长度可能与这一段相同 不需要再去判断 
		}
	}
	return false;
}

int main()
{
	while(1)
	{
		cin>>n;
		if(n==0)
			return 0;
		sum=0;
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&l[i]);
			sum+=l[i];
		}
		sort(l+1,l+n+1,greater<int>());		//排序   
		for(int i=l[1];i<=sum;i++)			//最短为最长的一段,最长为总和 
		{
			memset(vis,0,sizeof(vis));		//标记清空 
			if(sum%i!=0)					//剪枝  所有的总长除以数量应该为整数 
				continue;					
			num=sum/i;
			if(dfs(1,0,0,i))
			{
				cout<<i<<endl;
				break;
			}
		}
	}
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值