POJ 2739 Sum of Consecutive Prime Numbers

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2

大意:给定几个数,判断它是否可由若干个连续的质数相加得来,求此相加格式的种数

思路:将10000以内的质数从小到大存入数组,从前向后枚举即可

#include<iostream>
#include<cstdio>
#include<string>
#include<memory>
#include<algorithm>
#include<iomanip>
#include<cstring>
#include<cmath>
using namespace std;
bool fun(int n)
{
	for (int i = 2; i <= sqrtf(n); i++)	//sqrtf无歧义 sqrt编译器易产生歧义
	{
		if (n%i == 0)return false;
	}
	return true;
}
int arr[1500];
int x = 0;
int main()
{
	int n = 0;
	for (int i = 2; i <= 10000; i++)	//先确定10000内的质数
	{
		if (fun(i))
		{
			arr[n++] = i;
		}
	}
	int T = 0;
	while (cin >> x&&x)
	{
		T = 0;	//记录每个数的ans
		for (int i = 0;arr[i]<=x;i++)
		{
			int sum = 0;
			for (int j = i; sum < x&&j<1229; j++)	//前一万个自然数,有1229个质数 次循环不可超过1229 
				sum += arr[j];
			if (sum == x)
				T++;
		}
		cout << T << endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值