HDU 3415 Max Sum of Max-K-sub-sequence

题目链接:Problem - 3415 (hdu.edu.cn)

Problem Description

Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases.
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.

Sample Input

 

4

6 3

6 -1 2 -6 5 -5

6 4

6 -1 2 -6 5 -5

6 3

-1 2 -6 5 -5 6

6 6

-1 -1 -1 -1 -1 -1

Sample Output

 

7 1 3

7 1 3

7 6 2

-1 1 1

题意:这是一个长度为n的圆序列,n后面的序列是1,求长度不超过k的连续子序列的最大和

思路:这题可以用单调队列完成,我们先求出前缀和,然后维护一个递增的单调队列,单调队列记录的是一个区间的头,然后i为区间的尾部,区间和用差值可以解决,然后更新最大值和头尾即可

#include<bits/stdc++.h>
using namespace std;
#define maxn 200007

int sum[maxn];
int arr[maxn];
int p[maxn];

int main(){
	ios::sync_with_stdio(false);
	int t;
	int n, k;
	cin >> t;
	while(t--){
		cin >> n >> k;
		for(int i = 1; i <= n; i++){
			cin >> arr[i];
			arr[i + n] = arr[i];
		}
		sum[0] = 0;
		for(int i = 1; i <= n + k; i++){
			sum[i] = sum[i - 1] + arr[i];
		}
		int h = 1, t = 0;
		int ans = -100000005;
		int tou, wei;
		for(int i = 1; i <= n + k; i++){
			while(h <= t && sum[p[t]] > sum[i - 1]){
				t--;
			}
			p[++t] = i - 1;
			while(h <= t && i - 1 - k >= p[h]){
				h++;
			}
			if(sum[i] - sum[p[h]] > ans){
				ans = sum[i] - sum[p[h]];
				tou = p[h] + 1;
				wei = i;
			}
		}
		if(tou > n){
			tou -= n;
		}
		if(wei > n){
			wei -= n;
		}
		cout << ans << " " << tou << " " << wei << endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值