POJ 1742 Coins 动态规划多重背包

这是一道多重背包的动态规划的题目。
问有多少种。
传送门
Description
People in Silverland use coins.They have coins of value A1,A2,A3…An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input
The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output
For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

题意

给定几种不同面额的硬币若干枚,需要求的用这些硬币可以组成多少种范围在1~m的不同面额的组合。
输出对于每组数据输出可能的组合数。

解题思路

通过循环递推找出小于价钱的数,然后再判断我是否有这个能力(有那么多的钱以及张数)去组合成这个钱的数量。

#include<bits/stdc++.h>
using namespace std;
#define ll long long int
#define MAXN 100005
#define IOS ios::sync_with_stdio(false)
#define FRE freopen("1.txt", "r", stdin)
int dp[MAXN], re[MAXN], num[MAXN];
void init(){
	for(int i = 0; i < MAXN; i++) dp[i] = 1;
}
int n, k, ans;
void DP(){
	int sum[MAXN];   //记录硬币的出现次数   并在每一次的选择后清空。 
	//其中sum里面记录的是当前的组合成的钱 从我的二重循环可以看出我的j是什么 用来干什么
	for(int i = 0; i < n; i++){
		memset(sum, 0, sizeof(sum));
		for(int j = re[i]; j <= k; j++){
			if(!dp[j] && dp[j - re[i]] && sum[j - re[i]] < num[i]){
				dp[j] = 1;
				sum[j] = sum[j - re[i]] + 1;
				ans++;
			}
		}
	}
}
int main(int argc, char** argv){
	IOS;
	while(cin >> n >> k){
		memset(dp, 0, sizeof(dp));
		dp[0] = 1;
		ans = 0;
		if(n == 0 && k == 0) break;
		for(int i = 0; i < n; i++) cin >> re[i];
		for(int i = 0; i < n; i++) cin >> num[i];
		DP();
		cout << ans << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Raoxiaomi.

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值