1.题目描述:
给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。
输入格式:
输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。
输出格式:
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2
分析:
代码展示:
#include <iostream>
#include <cstring>
#include <algorithm>
#include <unordered_map>
#include <queue>
using namespace std;
const int N = 40;
int n,count1;
int postorder[N], inorder[N]; //后序遍历,中序遍历
unordered_map<int, int> l, r, pos; //用哈希表模拟二叉树
int build(int il, int ir, int pl, int pr)
{
int root = postorder[pr];
int k = pos[root]; //得到根节点在中序遍历中的下标
//k大于il表示根节点左边还有节点,即当前根节点存在左子树,下同
//下面两行是难点,举例解释见图
if (il < k) l[root] = build(il, k - 1, pl, pl + k - 1 - il);
if (ir > k) r[root] = build(k + 1, ir, pl + k - il, pr - 1);
return root;
}
void bfs(int root) //BFS用来层序遍历输出
{
queue<int> q;
q.push(root);
while (q.size())
{
auto t = q.front();
q.pop();
if(count1==0)cout<<t;
else cout <<" "<<t;
count1++;
if (l.count(t)) q.push(l[t]); //判断该节点的左右儿子是否存在
if (r.count(t)) q.push(r[t]); //存在则加入队列,等待下一层遍历
}
}
int main()
{
cin >> n;
for (int i = 0; i < n; i ++ ) cin >> postorder[i];
for (int i = 0; i < n; i ++ )
{
cin >> inorder[i];
pos[inorder[i]] = i; //记录中序遍历每个点位置(剪枝)
}
int root = build(0, n - 1, 0, n - 1); //参数为中序遍历区间和后序遍历区间
bfs(root);
return 0;
}
原题链接:PTA | 程序设计类实验辅助教学平台