本题要求实现一个函数,对给定的正整数N,打印从1到N的全部正整数。
函数接口定义:
void PrintN ( int N );
其中N是用户传入的参数。该函数必须将从1到N的全部正整数顺序打印出来,每个数字占1行。
裁判测试程序样例:
#include <stdio.h>
void PrintN ( int N );
int main ()
{
int N;
scanf("%d", &N);
PrintN( N );
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
3
输出样例:
1
2
3
代码:
c语言版:
#include <stdio.h>
void PrintN ( int N );
int main ()
{
int N;
scanf("%d", &N);
PrintN( N );
return 0;
}
void PrintN( int N )
{
for(int i=1;i<=N;i++)
{
printf("%d\n",i);
}
}
PTA提交结果:
注意,在提交时仅需提交函数部分,不是完整的代码。
测试结果如下:
Java版:
public class Main {
private static void PrintN(int N) {
for (int i=1; i<=N; i++) {
System.out.println(i);
}
}
public static void main(String[] args) {
Scanner scan= new Scanner(System.in);
if (scan.hasNextInt()) {
PrintN(scan.nextInt());
}
scan.close();
}
}