Roadblocks-dijkstra优化

Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1…N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R
Lines 2…R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output

Line 1: The length of the second shortest path between node 1 and node N
Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100
Sample Output

450
题意:这一题的意思就是给你无向路求1-n的第二短距离是多少要求必须比最短路小;
代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
typedef pair<int,int>PII;//这个东西就是把两个变量压缩为一个
const int N=2100100,INF=0x3f3f3f3f;
int head[N],cnt,dist[N],dist1[N];
struct l
{
	int next,to,val;
}dis[N];
void add(int from,int to,int val)//建邻接表
{
	dis[++cnt].to=to;
	dis[cnt].val=val;
	dis[cnt].next=head[from];
	head[from]=cnt;
}
void diss()
{
	priority_queue<PII ,vector<PII> ,greater<PII> >q;//建一个队列
	memset(dist,INF,sizeof(dist));
	memset(dist1,INF,sizeof(dist1));
	dist[1]=0;//把到起点距离记为0;
	q.push({0,1});//往队列存的的东西的意思是起点到第二个变量的距离为第一个变量
	while(!q.empty())
	{
		int i;
		PII x=q.top();
		q.pop();
		int u=x.second,vall=x.first;
		for(i=head[u];i;i=dis[i].next)//循环当前点能够到达的所有点
		{
			//printf(">>%d\n",dis[i].to);
			int v=dis[i].to;
			//printf("<<%d %d\n",v,vall+dis[i].val);
			if(dist[dis[i].to]>vall+dis[i].val)//更新最短路
			{
				
				dist[dis[i].to]=vall+dis[i].val;
				q.push({dist[dis[i].to],dis[i].to});
			}
			if(dist1[dis[i].to]>vall+dis[i].val&&dist[dis[i].to]<vall+dis[i].val)//更新次短路 特别要注意只有满足这个if判断时才能更新次短路
			{//printf("<<1\n");
				dist1[dis[i].to]=vall+dis[i].val;
				q.push({dist1[dis[i].to],dis[i].to});
			}
		}
	}
}
int main()
{
	int n,m,i,j;
	scanf("%d %d",&n,&m);
	for(i=0;i<m;i++)
	{
		int a,b,c;
		scanf("%d %d %d",&a,&b,&c);
		add(a,b,c);
		add(b,a,c);
	}
	diss();
	printf("%d\n",dist1[n]);
} 
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值