Round Numbers-数位dp

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone’ (also known as ‘Rock, Paper, Scissors’, ‘Ro, Sham, Bo’, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can’t even flip a coin because it’s so hard to toss using hooves.

They have thus resorted to “round number” matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both “round numbers”, the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a “round number” if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many “round numbers” are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input
Line 1: Two space-separated integers, respectively Start and Finish.
Output
Line 1: A single integer that is the count of round numbers in the inclusive range Start…Finish
Sample Input
2 12
Sample Output
6
思路:这么大的数据暴力是肯定不行的 ,所以这个题要用dp来解决
代码:

#include<stdio.h>
#include<string.h>
int dp[50][50][50],b[1000];
int dfs(int pos,int num,int num1,int lim,int first)
{
	int i;
	if(!lim&&dp[pos][num][num1]!=-1) return dp[pos][num][num1];//这里相当于记忆化
	if(pos<=0) return num>=num1;//如果pos<=0就证明这个数已经走完了直接返回就行
	int maxx=lim?b[pos]:1,ans=0;//这里是判断他的上界,lim是判断它当前是否受限制,如果受的话那就是它本身,否则就为1,因为是二进制所以最大为1
	for(i=0;i<=maxx;i++)
	{
		if(first==1)//first判断是否出现过1
		{
			ans+=dfs(pos-1,num+(i==0),num1+(i==1),lim&&(i==maxx),first);
		}
		else
		{
			ans+=dfs(pos-1,0,i,lim&&(i==maxx),i);
		}
	}
	if(!lim) dp[pos][num][num1]=ans;
	return ans;
}
int solve(int n)//存n的二进制
{
	int k=0;
	while(n!=0)
	{
		b[++k]=n%2;
		n/=2;
	}
	return dfs(k,0,0,1,0);
}
int main()
{
	int n,m;
	memset(dp,-1,sizeof(dp));
	scanf("%d %d",&n,&m);
	printf("%d\n",solve(m)-solve(n-1));
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值