K - Coprime Sequence

Do you know what is called ``Coprime Sequence''? That is a sequence consists of nn positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1. 
``Coprime Sequence'' is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.

Input

The first line of the input contains an integer T(1≤T≤10)T(1≤T≤10), denoting the number of test cases. 
In each test case, there is an integer n(3≤n≤100000)n(3≤n≤100000) in the first line, denoting the number of integers in the sequence. 
Then the following line consists of nn integers a1,a2,...,an(1≤ai≤109)a1,a2,...,an(1≤ai≤109), denoting the elements in the sequence.

Output

For each test case, print a single line containing a single integer, denoting the maximum GCD.

Sample Input

3
3
1 1 1
5
2 2 2 3 2
4
1 2 4 8

Sample Output

1
2
2

/* HDU6025 Coprime Sequence */
 
#include <iostream>
#include<algorithm>
 
using namespace std;
 
const int N = 100000;
int a[N], prefixgcd[N], suffixgcd[N];
 
inline int gcd(int a, int b) {
    return b == 0 ? a : gcd(b, a % b);
}
 
int main()
{
    int t, n;
 
    cin >> t;
    while(t--) {
        cin >> n;
 
        for(int i=0; i<n; i++)
            cin >> a[i];
 
        // 计算前缀GCD
        prefixgcd[0] = a[0];
        for(int i=1; i<n; i++)
            prefixgcd[i] = gcd(prefixgcd[i - 1], a[i]);
 
        // 计算后缀GCD
        suffixgcd[n - 1] = a[n - 1];
        for(int i=n-2; i>=0; i--)
            suffixgcd[i] = gcd(a[i], suffixgcd[i + 1]);
 
        int ans = max(suffixgcd[1], prefixgcd[n - 2]);
        for(int i=1; i<n - 1; i++)
            ans = max(ans, gcd(prefixgcd[i - 1], suffixgcd[i + 1]));
 
        cout << ans << endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

郭晋龙

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值