算法入门 22.Fliptile

168 篇文章 1 订阅
99 篇文章 1 订阅
这篇博客讨论了一种智力游戏,奶牛需要翻转一个M×N的网格中的瓷砖,使得所有瓷砖变为白色。每一步操作会翻转一个瓷砖及其相邻的瓷砖。目标是最小化翻转次数。程序通过模拟和搜索找到最少翻转次数的解决方案,并给出了具体的翻转位置。如果无法实现所有瓷砖变白,则输出"IMPOSSIBLE"。
摘要由CSDN通过智能技术生成

Fliptile

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 31420Accepted: 11064

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

Source

USACO 2007 Open Silver

#include<iostream>
using namespace std;
int N,M;
const int maxn=15;
int flip[maxn][maxn];
int dx[5]={-1,0,0,0,1};
int dy[5]={0,1,0,-1,1};
int tile[maxn][maxn];
int opt[maxn][maxn];
int get(int x,int y){
    int c;
    c=tile[x][y];
    for(int i=0;i<5;i++){
        int x2=x+dx[i];
        int y2=y+dy[i];
        if(x2>=0&&x2<M&&y2>=0&&y2<N){
            c+=flip[x2][y2];
        }
    }
    return c%2;
}
int calc(){
    int res=0;
    for(int i=1;i<M;i++){
        for(int j=0;j<N;j++){
            if(get(i-1,j)!=0){
                flip[i][j]=1;
            }
        }
    }
    for(int j=0;j<N;j++){
        if(get(M-1,j)!=0)
            return -1;
    }
    for(int i=0;i<M;i++){
        for(int j=0;j<N;j++){
            res+=flip[i][j];
        }
    }
    return  res;
}
void solve(){
    int res=-1;
    for(int i=0;i<1<<N;i++){
        memset(flip, 0, sizeof(flip));
        for(int j=0;j<N;j++){
            flip[0][N-j-1]=i>>j&1;
        }
    }
    int num=calc();
    if(num>=0&&(res<0||res>num)){
        res=num;
        memcpy(opt, flip,sizeof(flip));
    }
    if(res<0) cout<<"NO"<<endl;
    else{
        for(int i=0;i<M;i++){
            for(int j=0;j<N;j++){
                cout<<opt[i][j]<<" ";
            }
            cout<<endl;
        }
    }
}
void init(){
    cin>>N>>M;
    for(int i=0;i<M;i++){
        for(int j=0;j<N;j++){
            cin>>tile[i][j];
        }
    }
}
int main(){
    init();
    solve();
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

郭晋龙

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值