Knight Moves -骑士移动 (BFS广搜)

Knight Moves -骑士移动  POJ - 2243 

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input

The input will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

您的一位朋友正在研究旅行骑士问题 (TKP),您将在其中找到最短的封闭式骑士移动旅行,该旅行只访问棋盘上给定的一组 n 个方格中的每个方格一次。他认为这个问题最困难的部分是确定两个给定方格之间的最小骑士移动次数,一旦你完成了这一点,就很容易找到巡回赛。
你当然知道反之亦然。所以你让他写一个解决“困难”部分的程序。

您的工作是编写一个程序,将两个正方形 a 和 b 作为输入,然后确定从 a 到 b 的最短路径上的骑士移动次数。

输入

输入将包含一个或多个测试用例。每个测试用例由一行包含两个由一个空格分隔的正方形组成。正方形是棋盘上由代表列的字母(ah)和代表行的数字(1-8)组成的字符串。

输出

对于每个测试用例,打印一行说“To get from xx to yy takes n knight moves.”。
 

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.


AC

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
int step;
int to[8][2] = {-2,1,-1,2,1,2,2,1,2,-1,1,-2,-1,-2,-2,-1};//骑士移动的8个方位
int map[10][10],ex,ey;
char s1[5],s2[5];
struct node//记录步数 
{
    int x,y,step;
};
int check(int x,int y)//检查是否超界 
{
    if(x<0 || y<0 || x>=8 || y>=8 || map[x][y])
    return 1;//非正常终止 
    return 0;//正常终止 
}
int bfs()
{
    int i;
    queue<node> Q;
    node p,next,q;
    p.x = s1[0]-'a';// 转化成数字形式,方便利用坐标 
    p.y = s1[1]-'1';
    p.step = 0;
    ex = s2[0]-'a';
    ey = s2[1]-'1';
    memset(map,0,sizeof(map));
    map[p.x][p.y] = 1;
    Q.push(p);
    while(!Q.empty())
    {
        q = Q.front();
        Q.pop();
        if(q.x == ex && q.y == ey)//如果当前是要求到的位置 
        return q.step;//输出走的步数 代表下面输出的bfs的值
        for(i = 0;i<8;i++)//不是的话开始遍历其他方向 
        {
            next.x = q.x+to[i][0];
            next.y = q.y+to[i][1];
            if(next.x == ex && next.y == ey)
            return q.step+1; 
            if(check(next.x,next.y))//如果这个点不合法超边界的话,跳出这个方向的循环 
            	continue;
            next.step = q.step+1;//如果合法,步数+1 
            map[next.x][next.y] = 1;
            Q.push(next); //处理的时候先处理先进队列的合法位置点 
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%s%s",s1,s2))
    {
        printf("To get from %s to %s takes %d knight moves.\n",s1,s2,bfs());
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值