模拟——Second Order Statistics

Second Order Statistics

题面翻译

题面描述

给定一个数组,输出其中第二小的整数(相等的整数只计算一次)。

输入格式

第一行,一个整数 n n n 1 ≤ n ≤ 100 1 \leq n \leq 100 1n100),表示数组长度。

第二行, n n n 个绝对值小于 100 100 100 的整数。

输出格式

一行。如果该数组存在第二小整数,则输出第二小整数。如果不存在,则输出NO

题目描述

Once Bob needed to find the second order statistics of a sequence of integer numbers. Lets choose each number from the sequence exactly once and sort them. The value on the second position is the second order statistics of the given sequence. In other words it is the smallest element strictly greater than the minimum. Help Bob solve this problem.

输入格式

The first input line contains integer $ n $ ( $ 1<=n<=100 $ ) — amount of numbers in the sequence. The second line contains $ n $ space-separated integer numbers — elements of the sequence. These numbers don’t exceed 100 in absolute value.

输出格式

If the given sequence has the second order statistics, output this order statistics, otherwise output NO.

样例 #1

样例输入 #1

4
1 2 2 -4

样例输出 #1

1

样例 #2

样例输入 #2

5
1 2 3 1 1

样例输出 #2

2

代码

#include<iostream>
#include<algorithm>
#include<vector>

using namespace std;

const int N = 110;

int n;
vector<int>w;

int main(){
    cin>>n;
    
    for(int i=1;i<=n;i++){
        int x;
        cin>>x;
        w.push_back(x);
    }
    
    sort(w.begin(),w.end());
    
    w.erase(unique(w.begin(),w.end()),w.end());
    
    
    if(w.size()<2){
        puts("NO");
    }else
    cout<<w[1];
    
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

green qwq

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值