1014 Waiting in Line/排队等候(STL——queue实现+模拟+读题)

95 篇文章 0 订阅

1014 Waiting in Line/排队等候

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[​i] will take T[​i] minutes to have his/her transaction processed.
    The first N customers are assumed to be served at 8:00am.
    Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while custome​2​​ is served at window2. Customer
​3 will wait in front of window​1​​ and customer​4​​ will wait in front of window2. Customer​5​​ will wait behind the yellow line.

At 08:01, customer1 is done and customer​5​​ enters the line in front of window1 since that line seems shorter now. Customer2​​ will leave at 08:02, customer4​​ at 08:06, customer​3​​ at 08:07, and finally customer​5​​ at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

思路

  • 因为本道题有说每个顾客先到先得,每次选择最短的队伍,按照这么说,我们此时就按照顾客来枚举。
  • 对于排队问题,我们经常来说用的都是队列,但由于本道题队伍很多,因此我们开 25 25 25 个队列。
  • 然后对于每位顾客,每次寻找最快的队伍(此时只需要看队伍的大小)(如果我们在枚举最快队伍的过程中,就连最快的队伍都是大于 m m m 的了,此时我们就得开始出队列了,枚举哪个截止时间最短,然后把它的弹出来,然后此时就可以把我们新的加进去了,然后更新我们的截止时间,也就是此时队尾的时间+当前顾客需要问的时间),我们的队列里面装的是最后一位顾客的截止时间。
  • 注意:这里17:00说的是不再接受新的服务,原先没有完成的服务还是能进行下去的。

代码

#include<iostream>
#include<queue>

using namespace std;

const int N = 1010;

int be[N],ed[N];
queue<int> q[25];
int n,m,k,Q;

int main(){
    cin>>n>>m>>k>>Q;
    
    for(int i=1;i<=k;i++){
        int x;
        cin>>x;
        int fast=1;
        
        for(int j=1;j<=n;j++){
            if(q[fast].size()>q[j].size()){
                fast=j;
            }
        }
        
        if(q[fast].size()>=m){
            for(int j=1;j<=n;j++){
                if(q[fast].front()>q[j].front()){
                    fast=j;
                }
            }
        }
        
        be[i]=(q[fast].size()?q[fast].back():0);
        
        if(q[fast].size()>=m){
            q[fast].pop();
        }
        
        ed[i]=be[i]+x;
        
        q[fast].push(ed[i]);
        
    }
    
    
    while(Q--){
        int x;
        cin>>x;
        if(be[x]>=540){
            puts("Sorry");
        }else
            printf("%02d:%02d\n",8+ed[x]/60,ed[x]%60);
    }
    
    return 0;
}
  • 11
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

green qwq

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值