Number of Ways

描述:

You've got array a[1], a[2], ..., a[n], consisting of n integers. Count the number of ways to split all the elements of the array into three contiguous parts so that the sum of elements in each part is the same.

More formally, you need to find the number of such pairs of indices i, j (2 ≤ i ≤ j ≤ n - 1), that .

输入:

The first line contains integer n (1 ≤ n ≤ 5·105), showing how many numbers are in the array. The second line contains n integers a[1], a[2], ..., a[n] (|a[i]| ≤  109) — the elements of array a.

输出:

Print a single integer — the number of ways to split the array into three parts with the same sum.

样例输入:

5
1 2 3 0 3

复制

样例输出:

2

复制

样例输入:

4
0 1 -1 0

复制

样例输出:

1

复制

样例输入:

2
4 1

复制

样例输出:

0

关于本题目的思路,在数值的判定下多下功夫,不是3的倍数的不要,长度小于3的不要,对于low_bound的使用是为了防止有重复的元素被加进去,所以要在那里加上这一句判断。

#include<cstdio>
#include<vector>
#include<iostream>
using namespace std;
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int an[500005];
		long long sum=0,si=0,sj=0,cnt=0,ave;
		vector <int> fr;
		for(int i=0;i<n;i++)
		{
			scanf("%lld",&an[i]);
			sum+=an[i];
		}
		if(n<3||sum%3!=0)
		{
			printf("0\n");
			continue;
		}
		if(sum==0)
		{
			printf("0\n");
			continue;
		}
		ave=sum/3;
		for(int i=0;i<n-2;i++)
		{
			si+=an[i];
			if(si==ave)
				fr.push_back(i);			
		}
		for(int i=n-1;i>1;i--)
		{
			sj+=an[i];
			if(sj==ave)
			{
				cnt+=fr.end()-fr.begin();
			}			
		}
		printf("%lld\n",cnt);
	}
	return 0;
 } 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值