Roads in the North

描述:

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice.
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area.

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1.

输入:

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

输出:

You are to output a single integer: the road distance between the two most remote villages in the area.

样例输入:

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

复制

样例输出:

22

对于结果要进行俩次递归,先拿1点做起点,在拿离1点最远的点做起点,就可以找到最长的距离。

#include<iostream>
#include<vector>
#include<queue>
using namespace std;
struct temp{
	int val,end;
	temp(int vv,int ee):val(vv),end(ee){}
};
vector<temp> bns[1010];
int result=0,F;
bool visited[1010];
int f[1010];
int dfs(int n)
{
	fill(f,f+1010,0);
	fill(visited,visited+1010,false);
	queue<int> ans;
	ans.push(n);
	visited[n]=true;
	f[n]=0;
	while(!ans.empty())
	{
		int i=ans.front();
		ans.pop();
		if(f[i]>result)
		{
			result=f[i];
			F=i;
		}
		for(int n=0;n<bns[i].size();n++)
		{
			temp j=bns[i][n];
			if(!visited[j.end])
			{
				visited[j.end]=true;
				f[j.end]=f[i]+j.val;
				ans.push(j.end);
			}
		}
	}
	return F;
}
int main()
{
	int sum1,sum2,sum3;
	while(scanf("%d %d %d",&sum1,&sum2,&sum3)!=EOF)
	{
		bns[sum1].push_back(temp(sum3,sum2));
		bns[sum2].push_back(temp(sum3,Msum1));
	}
	int point=dfs(1);
	dfs(point);
	cout<<result<<endl;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值