一、实验拓扑:
二、实验步骤:
1、配置基本的IGP互联。
2、接入设备上配置流分类,将不同的业务流量区分开。
3、入方向配置流量监管。
4、出方向配置拥塞避免、拥塞管理和流量整形。
三、实验具体配置:
1、SW1:
vlan batch 10 20 30 100
interface Vlanif10
ip address 192.168.10.254 255.255.255.0
interface Vlanif20
ip address 192.168.20.254 255.255.255.0
interface Vlanif30
ip address 192.168.30.254 255.255.255.0
interface Vlanif100
ip address 10.10.100.1 255.255.255.252
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 100
interface GigabitEthernet0/0/3
port link-type access
port default vlan 10
interface GigabitEthernet0/0/4
port link-type access
port default vlan 20
interface GigabitEthernet0/0/5
port link-type access
port default vlan 30
ospf 10 router-id 10.10.10.10
import-route direct
area 0.0.0.1
network 10.10.100.0 0.0.0.3
配置流分类:
acl number 3001
rule 5 permit ip source 192.168.10.0 0.0.0.255
acl number 3002
rule 5 permit ip source 192.168.20.0 0.0.0.255
acl number 3003
rule 5 permit ip source 192.168.30.0 0.0.0.255
traffic classifier data(创建流分类data)
if-match acl 3003(匹配acl 3003)
traffic classifier video
if-match acl 3002
traffic classifier voice
if-match acl 3001
traffic behavior data(创建流行为)
remark 8021p 4(重标记VLAN报文的802.1p优先级为4)
traffic behavior video
remark 8021p 5
traffic behavior voice
remark 8021p 6
traffic policy data(创建流策略data)
classifier data behavior data(绑定流分类和流行为)
traffic policy video
classifier video behavior video
traffic policy voice
classifier voice behavior voice
interface GigabitEthernet0/0/3
traffic-policy voice inbound(在接口入方向应用流策略voice)
interface GigabitEthernet0/0/4
traffic-policy video inbound
interface GigabitEthernet0/0/5
traffic-policy data inbound
2、SW2:
vlan batch 100 200
interface Vlanif100
ip address 10.10.100.2 255.255.255.252
interface Vlanif200
ip address 10.10.200.2 255.255.255.252
interface GigabitEthernet0/0/1
port link-type access
port default vlan 200
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 100
ospf 10 router-id 20.20.20.20
area 0.0.0.0
network 10.10.200.0 0.0.0.3
area 0.0.0.1
network 10.10.100.0 0.0.0.3
流量监管:
traffic classifier tc1
if-match any(匹配所有数据报文)
traffic behavior tb1
car cir 100000 pir 300000 cbs 12500000 pbs 37500000(创建流量监管动作为双速双桶)
traffic policy tp1
classifier tc1 behavior tb1
interface GigabitEthernet0/0/2
traffic-policy tp1 inbound
拥塞避免:
diffserv domain dd1(创建DS域为dd1)
8021p-inbound 4 phb ef red(配置入方向VLAN报文的802.1p优先级和PHB之间的映射关系为EF并标记报文为红色)
8021p-inbound 5 phb ef yellow
8021p-inbound 6 phb ef green
drop-profile wred1(创建WRED丢弃模板)
color green low-limit 80 high-limit 100 discard-percentage 80(配置绿色报文80的低门限百分比、10高门限百分比和80的丢弃概率)
color yellow low-limit 70 high-limit 80 discard-percentage 90
color red low-limit 50 high-limit 70 discard-percentage 100
interface GigabitEthernet0/0/1
qos queue 4 wred wred1(在接口下应用WRED丢弃模板)
qos queue 5 wred wred1
qos queue 6 wred wred1
拥塞管理:
interface GigabitEthernet0/0/1
qos pq(在接口下应用优先级队列调度PQ)
流量整形:
interface GigabitEthernet0/0/1
qos queue 4 shaping cir 100000 pir 100000 cbs 150000 pbs 150000(在接口下指定队列4的队列整形功能为单速单桶)
qos queue 5 shaping cir 200000 pir 200000 cbs 250000 pbs 250000(在接口下指定队列5的队列整形功能为单速单桶)
qos queue 6 shaping cir 100000 pir 200000 cbs 400000 pbs 800000(在接口下指定队列6的队列整形功能为双速双桶)
3、AR1:
interface GigabitEthernet0/0/1
ip address 10.10.200.1 255.255.255.252
interface LoopBack10
ip address 1.1.1.1 255.255.255.255
ospf 10 router-id 1.1.1.1
import-route direct
area 0.0.0.0
network 10.10.200.0 0.0.0.3
接口限速:
interface GigabitEthernet0/0/1
qos lr pct 95(限制接口发送报文速率占接口带宽的95%)
四、配置检查: