题目
在一个社区里,每个人都有自己的小圈子,还可能同时属于很多不同的朋友圈。我们认为朋友的朋友都算在一个部落里,于是要请你统计一下,在一个给定社区中,到底有多少个互不相交的部落?并且检查任意两个人是否属于同一个部落。
输入格式:
输入在第一行给出一个正整数N(≤104 ),是已知小圈子的个数。随后N行,每行按下列格式给出一个小圈子里的人:
K P[1] P[2] ⋯ P[K]
其中K是小圈子里的人数,P[i](i=1,⋯,K)是小圈子里每个人的编号。这里所有人的编号从1开始连续编号,最大编号不会超过104 。
之后一行给出一个非负整数Q(≤104 ),是查询次数。随后Q行,每行给出一对被查询的人的编号。
输出格式:
首先在一行中输出这个社区的总人数、以及互不相交的部落的个数。随后对每一次查询,如果他们属于同一个部落,则在一行中输出Y,否则输出N。
输入样例:
4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7
输出样例:
10 2
Y
N
这题主要是考查集合的查找和并运算。我们认为有共同朋友的不同圈子就是属于同一个集合。
用Set数组代表大集合,所有集合都在这个大集合里,数组下标就是人的编号,值为对应编号的父节点 ,也就是代表一个小集合的根。
父节点的值我们设为该集合的元素数量,注意取负值!
大集合Set所有值初始化为-1。
每输入一个编号都要判断这个编号是否已经输入过了,如果已经输入过了,那么就代表这个编号所在集合应该跟已经存在的编号所属的集合合并。合并这里稍微有点儿复杂,请看具体代码实现,分开了root和普通元素两种情况。
注意人员编号从1开始,我在这里踩了坑。
代码
#include<stdio.h>
void initSet(int Set[], int length) {
for (int i = 0;i < length;i++)
Set[i] = -1;
}
int findRoot(int Set[], int data) {
if (Set[data] < 0)
return data;
else
return Set[data] = findRoot(Set, Set[data]); // 路径压缩
}
void unionSet(int Set[], int root1, int root2) {
if (Set[root1] > Set[root2]) {
Set[root2] += Set[root1];
Set[root1] = root2;
} else {
Set[root1] += Set[root2];
Set[root2] = root1;
}
}
int main() {
int circleCount, queryTimes, peopleCount, total = 0; // 圈子数、查询次数、圈子里的人数、总人数
int Set[10001]; // Set数组代表集合,数组下标就是人的编号,值为对应编号的父节点
initSet(Set, 10001);
scanf("%d", &circleCount);
for (int i = 0;i < circleCount;i++) {
scanf("%d", &peopleCount);
int root; // 单个圈子的根
scanf("%d", &root);
if (root > total)
total=root;
// 如果 Set[root] > 0,说明这个圈子可以跟其他圈子有共同朋友,可以组成一个集合
if (Set[root] > 0) {
int otherRoot = findRoot(Set, Set[root]);
Set[root] = otherRoot;
root = otherRoot;
} else {
Set[root] = -peopleCount;
}
int index; // 人的编号
for (int j = 0;j < peopleCount - 1;j++) {
scanf("%d", &index);
// 更新总人数和Set大小
if (index > total)
total = index;
// 如果 Set[index] > 0,说明这个圈子可以跟其他圈子有共同朋友,可以组成一个集合
if (Set[index] > 0) {
int otherRoot = findRoot(Set, Set[index]);
unionSet(Set, otherRoot, root);
} else {
Set[index] = root;
}
}
}
scanf("%d", &queryTimes);
circleCount = 0;
// 计算互不相交的部落数量
for (int i = 1;i <= total;i++)
if (Set[i] < 0)
circleCount++;
printf("%d %d\n", total, circleCount);
for (int i = 0;i < queryTimes;i++) {
int index1, index2;
scanf("%d%d", &index1, &index2);
findRoot(Set, index1) == findRoot(Set, index2) ? printf("Y\n") : printf("N\n");
}
return 0;
}