zcmu-1022: Primes on Interval(素筛+二分+区间和)

Description

You've decided to carry out a survey in the theory of prime numbers. Let us remind you that a prime number is a positive integer that has exactly two distinct positive integer divisors.

Consider positive integers aa + 1, ..., b (a ≤ b). You want to find the minimum integer l (1 ≤ l ≤ b - a + 1) such that for any integer x (a ≤ x ≤ b - l + 1) among l integers xx + 1, ..., x + l - 1 there are at least k prime numbers.

Find and print the required minimum l. If no value l meets the described limitations, print -1.

Input

Everay line contains three space-separated integers a, b, k (1 ≤ a, b, k ≤ 106; a ≤ b).

Output

In a single line print a single integer — the required minimum l. If there's no solution, print -1.

Sample Input

2 4 2
6 13 1
1 4 3

Sample Output

3
4
-1
代码:
#include<bits/stdc++.h>
using namespace std;
#define maxn 1000005
int a,b,k;
int prime[maxn]={0};
int sum[maxn]={0}; 
int find(int x){
    for(int i=a;i<=b-x+1;i++){
        if(sum[i+x-1]-sum[i-1]<k)
        return 0;
    }
    return 1;
}
int main(){
    for(int i=2;i<maxn;i++){
        sum[i]=sum[i-1];
        if(prime[i]==0){
            sum[i]++;
            for(int j=1;j*i<=maxn;j++){
                prime[i*j]=1;
            }
        }
    }
    while(~scanf("%d%d%d",&a,&b,&k)){
        if(sum[b]-sum[a-1]<k){
            cout<<"-1\n";
            continue;
        }
        int left=1;
        int right=b-a+1;
        int num;
        while(left<=right){
            int mid=(left+right)/2;
            if(find(mid)==1){
                num=mid;
                right=mid-1;
            }
            else left=mid+1;
        }
        printf("%d\n",num);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

emo的鱼香roise

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值