Real Big Water Problem

题目描述

If you have solved the small water problem,let's see this big one.If you don't,I suggest you ignore this problem!
Also give you a positive integer n.
Function F_x satisfies:
   F_0 = cos{n}
   F_x = cosF_{x-1} (x>0)
Calculate F_n.

输入格式

The input contains no more than 20 test cases.
For each test case,the only line consists of one integer n.
0<=n<=10^30.

输出格式

For each given n,print the answer in a single line.The result should be rounded to six decimal places.

输入样例

0
1
2
输出样例

1.000000
0.857553
0.610065
 

#include <iostream>

#include <cstdio>

#include<cmath>

#include<cstdlib>

#include<cstring>

using namespace std;

int function(double result,int t,int p){

  result=cos(result);

  if(t==p)printf("%.6lf\n",result);

  else function(result,t+1,p);

}

int main(){

  char n[100];

  double result;

  while(cin>>n){

    if(strlen(n)<=3){

      int t=0;

      int p=atoi(n);

      result=p;

      function(result,t,p);

    }

    else cout<<"0.739085"<<endl;

  }

  return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值