有一字符型单链表List,假设表中无重复值,现要按值查找,查找成功时返回指定值所在的位置,否则输出“not found”。
输入格式:
有多组数据,每组数据占两行,代表一次按值查找操作。 每组第一行有两个数,第一个为表长n(0<n<50),第二个为字符值x; 第二行为单链表的各元素值。
输出格式:
每组数据的输出占一行,具体输出如题。
输入样例:
在这里给出一组输入。例如:
5 d
abcde
结尾无空行
输出样例:
在这里给出相应的输出。例如:
4
结尾无空行
代码:
#include<stdio.h>
typedef struct List{
char s;
struct List *next;
}Node;
int main(){
Node *head,*p,*q,t;
int m,index=1,i;
char data;
char a;
while((scanf("%d %c",&m,&data))!=EOF){//注意输出要有空格
getchar();
index=1;
head=NULL;
for(i=0;i<m;i++){
scanf("%c",&a);
p=(Node)malloc(sizeof(Node));
p->s=a;
p->next=NULL;
if(headNULL){
head=p;
}
else{
q->next=p;
}
q=p;
}
t=head;
while(t!=NULL){
if(t->sdata){
break;
}
t=t->next;
index++;
}
if(t!=NULL){
printf("%d\n",index);
}
else{
printf(“not found\n”);
}
}
return 0;
}