3. 中序线索二叉树

3. 中序线索二叉树

【问题描述】创建一棵二叉树,接着中序线索化该二叉树,然后编写相应函数遍历该中序线索二叉树

【编码要求】线索二叉树遍历过程中不能使用递归、不能使用栈。

【输入形式】二叉树拓展的前序遍历序列

【输出形式】中序遍历序列

【样例输入】AB#D##CE###

【样例输出】BDAEC

#include <iostream>
using namespace std;
#include <cstring>
struct node
{
    char data;
    node *lchild;
    node *rchild;
    int ltag, rtag;
};
char a[100];
node *build(int len, int &i)
{
    if (i < len && a[i] != '#')
    {
        node *r = new node;
        r->data = a[i];
        r->ltag = r->rtag = 0;
        r->lchild = build(len, ++i);
        r->rchild = build(len, ++i);
        return r;
    }
    else
        return NULL;
}
node *pre = NULL;
void build_thread(node *root)
{
    if (root == NULL)
        return;
    build_thread(root->lchild);
    if (root->lchild == NULL)
    {
        root->lchild = pre;
        root->ltag = 1;
    }
    if (pre != NULL && pre->rchild == NULL)
    {
        pre->rchild = root;
        pre->rtag = 1;
    }
    pre = root;
    build_thread(root->rchild);
}

node *left(node *p)
{
    while (p != NULL && p->ltag == 0 && p->lchild != NULL)
        p = p->lchild;
    return p;
}
void output(node *root)
{
    node *p = left(root);
    while (p != NULL)
    {
        cout << p->data;
        if (p->rtag == 1)
        {
            p = p->rchild;
        }
        else
        {
            p = left(p->rchild);
        }
    }
    return;
}

int main()
{
    ios::sync_with_stdio(false);
    cin >> a;
    int i = 0;
    node *r = build(strlen(a), i);
    build_thread(r);
    output(r);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wrong Ansewer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值