输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。
输入格式:
第一行输入整数N(1<=N<=100000)。
第二行依次输入N个整数。 (保证奇数偶数都存在)
输出格式:
第一行分别输出偶数链表与奇数链表的元素个数;
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。
输入样例:
10
1 3 22 8 15 999 9 44 6 1001
输出样例:
4 6
22 8 44 6
1 3 15 999 9 1001
#include<stdio.h>
#include <stdlib.h>
struct node
{
int data;
struct node *next;
};
int o=0,j=0;
struct node *creat(int n)
{
struct node *head,*tail,*p;
int i;
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
for(i=0;i<n;i++)
{
p=(struct node*)malloc(sizeof(struct node));
scanf("%d",&p->data);
p->next=NULL;
tail->next=p;
tail=p;
}
return (head);
}
struct node *split(struct node *head1)
{
struct node *head2,*p,*q,*tail1,*tail2;
head2=(struct node *)malloc(sizeof(struct node));
head2->next=NULL;
p=head1->next;
head1->next=NULL;
q=p->next;
tail2=head2;
tail1=head1;
while(p!=NULL)
{
if(p->data%2==0)
{
o++;
p->next=NULL;
tail1->next=p;
tail1=p;
}
else
{
j++;
p->next=NULL;
tail2->next=p;
tail2=p;
}
p=q;
if(q!=NULL)
{
q=q->next;
}
}
return (head2);
}
void pri(struct node *p)
{
while(p)
{
if(p->next==NULL)printf("%d\n",p->data);
else printf("%d ",p->data);
p=p->next;
}
}
int main()
{
int n;
struct node *head1,*head2;
scanf("%d",&n);
head1=creat(n);
head2=split(head1);
printf("%d %d\n",o,j);
pri(head1->next);
pri(head2->next);
return 0;
}