1019 General Palindromic Number (20 分)-PAT甲级

A number that will be the same when it is written forwards(向前) or backwards(向后) is known as a Palindromic Number(回文数). For example, 1234321 is a palindromic number. All single digit(个位数) numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept(概念) of palindromicity(回文性) can be applied to(适用于) the natural numbers in any numeral system(数字系统). Consider a number N>0 in base b≥2, where it is written in standard notation(记号) with k+1 digits ai​ as ∑i=0k​(ai​bi). Here, as usual, 0≤ai​<b for all i and ak​ is non-zero. Then N is palindromic if and only if ai​=ak−i​ for all i. Zero is written 0 in any base and is also palindromic by definition(定义).

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤109 is the decimal number and 2≤b≤109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "ak​ ak−1​ ... a0​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

思路: 1.用两个vector容器保存给定数进制转换后的形式(当然是逆转后的形式),再将其中一个容器reverse,判断是否相等。

             2.开始的时候由于思维局限,只想到位数数字为个位的情况,导致测试点2和4没过,事实上并非如此,还可以是十位,百位等等。开始容器使用的是string,后来才改用的vector

             3.c++vector对“==”进行了运算符重载,使我们可以直接利用“==”判断两个vector容器是否完全相同(元素个数,元素类型,对应位置的元素完全相同才算“==”),当然这仅限于系统内置类型,自定义类型需要另外重写“==”运算符重载。

先贴以下错误代码 

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
int main()
{
	int n,d;
	cin>>n>>d;
	string s,ss;
	if(n==0)
		s="0";
	while(n>0)
	{
		s+=to_string(n%d); 
		n/=d;
	}
	ss=s;
	reverse(ss.begin(),ss.end());
	if(ss==s)
		cout<<"Yes"<<endl;
	else
		cout<<"No"<<endl;
	for(int i=0;i<ss.size();i++)
	{
		if(i!=0)
			cout<<" ";
		cout<<ss[i];
	}
	return 0;
}

AC代码

#include <iostream>
#include <vector>
#include <algorithm> 
using namespace std;
int main()
{
	vector<int> a,b;
	int n,d;
	cin>>n>>d;
	if(n==0)
	{
		a.push_back(n%d);
		b.push_back(n%d);
	}	
	while(n>0)
	{
		a.push_back(n%d);
		b.push_back(n%d);
		n/=d;
	}
	reverse(a.begin(),a.end());
	if(a==b)
		cout<<"Yes";
	else
		cout<<"No";
	cout<<endl;
	for(int i=0;i<a.size();i++)
	{
		if(i!=0)
			cout<<" ";
		cout<<a[i]; 
	} 
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值