1054 The Dominant Color (20 分)-PAT甲级

Behind the scenes(场景) in the computer's memory(内存), color is always talked about as a series of 24 bits of information for each pixel(像素). In an image, the color with the largest proportional area(比例面积) is called the dominant(占优势的、占主导地位的) color. A strictly dominant color takes more than half of the total area. Now given an image of resolution(分辨率) M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range(范围) [0,224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

题目大意:找出给定像素矩阵中某个出现次数大于总像素点个数一半的像素点 

 思路:1.考查的是哈希表的知识,将像素点的大小和该像素点出现次数进行哈希,输出出现次数最多的像素点大小即可。

2.题目还是比较简单的,难的是读懂题目(有很多的专业单词),这就要求我们在平时做题目的时候多多积累这些专业单词。

AC代码

#include <iostream>
#include <map> 
using namespace std;
int main() {
	int m, n;
	map<int, int> k;
	cin >> m >> n;
	int Max = -1;
	for (int i = 0; i < m * n; i++) {
		int temp;
		cin >> temp;
		k[temp]++;
		if (i == 0) Max = temp;
		else if (k[Max] < k[temp]) Max = temp;
	}
	cout << Max;
	return 0;
}

 更多PAT甲级题目:请访问PAT甲级刷题之路--题目索引+知识点分析(正在进行),感谢支持!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值