C - Persistent Numbers

Description

The multiplicative persistence of a number is defined by Neil Sloane (Neil J.A. Sloane in The Persistence of a Number published in Journal of Recreational Mathematics 6, 1973, pp. 97-98., 1973) as the number of steps to reach a one-digit number when repeatedly multiplying the digits. Example: 
679 -> 378 -> 168 -> 48 -> 32 -> 6.

That is, the persistence of 679 is 6. The persistence of a single digit number is 0. At the time of this writing it is known that there are numbers with the persistence of 11. It is not known whether there are numbers with the persistence of 12 but it is known that if they exists then the smallest of them would have more than 3000 digits. 
The problem that you are to solve here is: what is the smallest number such that the first step of computing its persistence results in the given number?
Input

For each test case there is a single line of input containing a decimal number with up to 1000 digits. A line containing -1 follows the last test case.
Output

For each test case you are to output one line containing one integer number satisfying the condition stated above or a statement saying that there is no such number in the format shown below.
Sample Input

0
1
4
7
18
49
51
768
-1

Sample Output

10
11
14
17
29
77
There is no such number.
2688
 

大致题意:如49,找到最小数字(77)满足7*7=49

                      768,2*6*8*8=768

题解:

高精度被除整数➗整数(个位)

位数为1的整数特判

从大到小寻找因子,使得下一次的被除数尽量小

除法模拟过程中不断进行char*与数字的转换,末尾'\0'

商字符串中含有前导0,记得去掉

当商的位数>1,找不到符合条件的数

#include<iostream>
using namespace std;
const int N = 1010;
char s[N], ans[N];//商
int num[3 * N];
bool iscount(int i) {
	int mod = 0, k = 0;
	char* q;
	for (int j = 0; s[j] != '\0'; j++) {//模拟除法
		mod = mod * 10 + s[j] - '0';//计算商的当前位,送入ans
		printf("mod:%d\n", mod);
		ans[k++] = mod / i + '0';
		mod %= i;
	}ans[k] = '\0';
	
	if (mod != 0)return 0;//最后余数非零,不能整除
	
	q = ans;
	while (*q == '0')q++;//去掉q前导的无用0
	int j;//复制更新被除数s
	for (j = 0; *q != '\0'; j++, q++)s[j] = *q;
	s[j] = '\0';
	return 1;
}
int main() {
	while (scanf("%s", s), s[0] != '-') {
		if (s[1] == '\0') {
			printf("1%s\n", s);
			continue;
		}int j = 0;
		
		for (int i = 9; i > 1; i--) {
			while (iscount(i)) {//是否整除
				printf("start:%d\n",i);
				num[++j] = i;
			}
		}
		//商的位数大于一
		if (strlen(s) > 1) {
			printf("There is no such number.\n");
			continue;
		}
		//倒序输出
		while (j > 0)printf("%d", num[j--]);
		printf("\n");
	}
	return 0;
}

#!/bin/bash #【重命名部分】 # 获取 lsusb 输出中匹配 “Que” 的前三行 # 注:这三行顺序即代表原始物理顺序,对应 SIM 卡槽顺序 raw_result=$(lsusb | grep Que | head -n 3 | awk '{print $4}' | tr -d ':') numbers=() turn=() # 去除前导零并存入数组 for num in $raw_result; do clean_num=$(echo "$num" | sed 's/^0*//') numbers+=("$clean_num") done # 第一阶段重命名: # 将系统默认接口 wwan0、wwan1、wwan2 临时重命名为 “wwan<bus设备号>” for i in "${!numbers[@]}"; do ip link set wwan$i down ip link set wwan$i name wwan${numbers[$i]} ip link set wwan${numbers[$i]} up done sorted_numbers=($(echo "${numbers[@]}" | tr ' ' '\n' | sort -n)) echo ${sorted_numbers[@]} # 第二阶段重命名: # 根据逻辑 NAME = 2 - i,对临时名称重新映射为最终名称 # 同时记录映射:最终接口名称 -> 原始接口索引 (0,1,2) # 将映射结果输出到 /mirror.log 文件 echo "映射关系:最终接口名称 -> 原始接口索引" > /mirror.log declare -A final_to_original for i in "${!sorted_numbers[@]}"; do ((final_index = 2- $i)) # 最终名称:wwan(2-i)(逻辑上,这里直接用 i,具体依据实际需求调整) current_name="wwan${sorted_numbers[$i]}" final_name="wwan${final_index}" ip link set "$current_name" down ip link set "$current_name" name "$final_name" ip link set "$final_name" up # 查找元素在 numbers 数组中的索引 for j in "${!numbers[@]}"; do if [ "${numbers[$j]}" -eq "${sorted_numbers[$i]}" ]; then index="$j" break fi done sleep 1 echo "wwan${final_index} -> ${index}" >> /mirror.log done,执行上述脚本报错rtnetlink answers: resource busy
03-29
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值