[UVA-1368] DNA Consensus String

该文讲述了生物学家Ahn在研究五种动物的DNA中发现基因X并寻求人类可能拥有的基因X的代表性DNA序列。通过使用汉明距离定义共识字符串,Ahn找出了基因X的最接近的DNA序列,并计算了与动物基因X的共识错误。文章提供了示例输入和输出,展示了如何找到字典序最小且与所有序列差异最小的DNA串。
摘要由CSDN通过智能技术生成

DNA (Deoxyribonucleic Acid) is the molecule which contains the genetic instructions. It consists of four different nucleotides, namely Adenine, Thymine, Guanine, and Cytosine as shown in Figure 1. If we represent a nucleotide by its initial character, a DNA strand can be regarded as a long string (sequence of characters) consisting of the four characters A, T, G, and C. For example, assume we are given some part of a DNA strand which is composed of the following sequence of nucleotides: 

``Thymine-Adenine-Adenine-Cytosine-Thymine-Guanine-Cytosine-Cytosine-Guanine-Adenine-Thymine" 


Then we can represent the above DNA strand with the string ``TAACTGCCGAT." The biologist Prof. Ahn found that a gene X commonly exists in the DNA strands of five different kinds of animals, namely dogs, cats, horses, cows, and monkeys. He also discovered that the DNA sequences of the gene X from each animal were very alike. See Figure 2. 


     DNA sequence of gene X 
Cat:     GCATATGGCTGTGCA
Dog:     GCAAATGGCTGTGCA
Horse:     GCTAATGGGTGTCCA
Cow:     GCAAATGGCTGTGCA
Monkey:     GCAAATCGGTGAGCA

Figure 2. DNA sequences of gene X in five animals. 

Prof. Ahn thought that humans might also have the gene X and decided to search for the DNA sequence of X in human DNA. However, before searching, he should define a representative DNA sequence of gene X because its sequences are not exactly the same in the DNA of the five animals. He decided to use the Hamming distance to define the representative sequence. The Hamming distance is the number of different characters at each position from two strings of equal length. For example, assume we are given the two strings ``AGCAT" and ``GGAAT." The Hamming distance of these two strings is 2 because the 1st and the 3rd characters of the two strings are different. Using the Hamming distance, we can define a representative string for a set of multiple strings of equal length. Given a set of strings S = s1,..., sm of length n , the consensus error between a string y of length n and the set S is the sum of the Hamming distances between y and each si in S . If the consensus error between y and S is the minimum among all possible strings y of length n , y is called a consensus string of S . For example, given the three strings ``AGCAT" `` AGACT" and `` GGAAT" the consensus string of the given strings is `` AGAAT" because the sum of the Hamming distances between `` AGAAT" and the three strings is 3 which is minimal. (In this case, the consensus string is unique, but in general, there can be more than one consensus string.) We use the consensus string as a representative of the DNA sequence. For the example of Figure 2 above, a consensus string of gene X is `` GCAAATGGCTGTGCA" and the consensus error is 7. 

Input 
Your program is to read from standard input. The input consists of  T  test cases. The number of test cases  T is given in the first line of the input. Each test case starts with a line containing two integers  m and  n which are separated by a single space. The integer  m  (4m50) represents the number of DNA sequences and  n  (4n1000) represents the length of the DNA sequences, respectively. In each of the next  m lines, each DNA sequence is given. 
Output 
Your program is to write to standard output. Print the consensus string in the first line of each case and the consensus error in the second line of each case. If there exists more than one consensus string, print the lexicographically smallest consensus string. The following shows sample input and output for three test cases. 
Sample Input 

5 8 
TATGATAC 
TAAGCTAC 
AAAGATCC 
TGAGATAC 
TAAGATGT 
4 10 
ACGTACGTAC 
CCGTACGTAG 
GCGTACGTAT 
TCGTACGTAA 
6 10 
ATGTTACCAT 
AAGTTACGAT 
AACAAAGCAA 
AAGTTACCTT 
AAGTTACCAA 
TACTTACCAA

Sample Output 
TAAGATAC 

ACGTACGTAA 

AAGTTACCAA 
12
 

题目的大体意思就是给你一个确定的而为字符数组,找出与每行字符数组相差的相同位置的不同元素数之和最小,并且保证字典序最小的。

思路:整体上就是遍历二维数组的每一列,找出每一列(注意是每一列,即每一竖行)中出现元素最多的元素即为答案数组元素(但是如果相同的元素不唯一的话,就要以字典序最小的为准)

AC代码:

注意数组边界问题(因为这个我还re了一次,找了好长时间,呜呜~)

#include <iostream>
#include <algorithm>
#include <sstream>
#include <string.h>
#include <cstdio>
using namespace std;
char function2(int a,int b,int c,int d)
{
    int temp1=max(a,b);
    int temp2=max(c,d);
    int temp3=max(temp1,temp2);
    if(temp3==a)
        return 'A';
    if(temp3==b)
        return 'C';
    if(temp3==c)
        return 'G';
    if(temp3==d)
        return 'T';

}
int main()
{
    int x;
    cin>>x;
    while(x--)
    {
        int a[1010][100]= {0};
        int n,m;
        cin>>m>>n;
        char**p=new char *[m];
        for(int i=0; i<m; i++)
            p[i]=new char [n];
        for(int i=0; i<m; i++)
            for(int j=0; j<n; j++)
                cin>>p[i][j];

        for(int i=0; i<m; i++)
            for(int j=0; j<n; j++)
            {
                a[j][p[i][j]]++;
            }
        string s;
        for(int i=0; i<n; i++)
        {

            s+=function2(a[i]['A'],a[i]['C'],a[i]['G'],a[i]['T']);

        }
        int sum=0;
        for(int i=0; i<m; i++)
            for(int j=0; j<n; j++)
            {
                if(p[i][j]!=s[j])
                    sum++;
            }
        cout<<s<<endl;
        cout<<sum<<endl;
        for(int i=0; i<m; i++)
            delete []p[i];
        delete []p;
    }
    return 0;

}
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值