1071 小赌怡情

常言道“小赌怡情”。这是一个很简单的小游戏:首先由计算机给出第一个整数;然后玩家下注赌第二个整数将会比第一个数大还是小;玩家下注 t 个筹码后,计算机给出第二个数。若玩家猜对了,则系统奖励玩家 t 个筹码;否则扣除玩家 t 个筹码。

注意:玩家下注的筹码数不能超过自己帐户上拥有的筹码数。当玩家输光了全部筹码后,游戏就结束。

输入格式:

输入在第一行给出 2 个正整数 T 和 K(≤ 100),分别是系统在初始状态下赠送给玩家的筹码数、以及需要处理的游戏次数。随后 K 行,每行对应一次游戏,顺序给出 4 个数字:

n1 b t n2

其中 n1 和 n2 是计算机先后给出的两个[0, 9]内的整数,保证两个数字不相等。b 为 0 表示玩家赌,为 1 表示玩家赌t 表示玩家下注的筹码数,保证在整型范围内。

输出格式:

对每一次游戏,根据下列情况对应输出(其中 t 是玩家下注量,x 是玩家当前持有的筹码量):

  • 玩家赢,输出 Win t! Total = x.
  • 玩家输,输出 Lose t. Total = x.
  • 玩家下注超过持有的筹码量,输出 Not enough tokens. Total = x.
  • 玩家输光后,输出 Game Over. 并结束程序。

输入样例 1:

100 4
8 0 100 2
3 1 50 1
5 1 200 6
7 0 200 8

输出样例 1:

Win 100!  Total = 200.
Lose 50.  Total = 150.
Not enough tokens.  Total = 150.
Not enough tokens.  Total = 150.

输入样例 2:

100 4
8 0 100 2
3 1 200 1
5 1 200 6
7 0 200 8

输出样例 2:

Win 100!  Total = 200.
Lose 200.  Total = 0.
Game Over.

实验代码:

package PTAPractice;

import java.util.Scanner;

public class Code1071 {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int chip = sc.nextInt();
        int num = sc.nextInt();
        int[][] arr1 = new int[num][4];

        for (int i = 0; i < arr1.length; i++) {
            for (int j = 0; j < arr1[i].length; j++) {
                arr1[i][j] = sc.nextInt();
            }
        }

        for (int i = 0; i < arr1.length; i++) {
            if ((arr1[i][3] < arr1[i][0]) && (arr1[i][1] == 0)) {
                if (arr1[i][2] > chip) {
                    System.out.println("Not enough tokens. Total= " + chip);
                } else if (chip == 0) {
                    System.out.println("Game Over.");
                } else {
                    chip = chip + arr1[i][2];
                    System.out.println("Win !" + arr1[i][2] + "!  Total=" + chip);
                }

            }
            if ((arr1[i][3] < arr1[i][0]) && (arr1[i][1] == 1)) {
                if (arr1[i][2] > chip) {
                    System.out.println("Not enough tokens. Total= " + chip);
                } else if (chip == 0) {
                    System.out.println("Game Over.");
                } else {
                    chip = chip - arr1[i][2];
                    System.out.println("Lose ." + arr1[i][2] + "!  Total=" + chip);
                }

            }
            if ((arr1[i][3] > arr1[i][0]) && (arr1[i][1] == 0)) {
                if (arr1[i][2] > chip) {
                    System.out.println("Not enough tokens. Total= " + chip);
                } else if (chip == 0) {
                    System.out.println("Game Over.");
                } else {
                    chip = chip - arr1[i][2];
                    System.out.println("Lose ." + arr1[i][2] + "!  Total=" + chip);
                }

            }
            if ((arr1[i][3] > arr1[i][0]) && (arr1[i][1] == 1)) {
                if (arr1[i][2] > chip) {
                    System.out.println("Not enough tokens. Total= " + chip);
                } else if (chip == 0) {
                    System.out.println("Game Over.");
                } else {
                    chip = chip + arr1[i][2];
                    System.out.println("Win !" + arr1[i][2] + "!  Total=" + chip);
                }

            }
        }
    }
}

 运行结果:

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值