账号密码:
competitor
Skills39!
cisco:
ntp:server: ntp master 1
client: ntp server <目标地址>
三层设置trunk后要封装:switchport trunk encapsulation dot1q
生成树快速端口:spanning-tree portfast
生成树模式:spanning-tree mode pvst
生成树优先级:spanning-tree vlan 20 priority 24567
hsrp虚拟ip:standby 1 ip 10.0.10.254
standby 1 preempt
优先级:standby 1 priority 120(115备用)
standby 1 track GigabitEthernet0/1
router eigrp 1
passive-interface Vlan10
passive-interface Vlan20
network 1.1.1.0 0.0.0.255
network 10.0.0.0 0.0.0.255
network 20.0.0.0 0.0.0.255
network 30.0.0.0 0.0.0.255
network 10.0.20.0 0.0.0.255
network 10.0.10.0 0.0.0.255
ipv6 enable
ipv6 address 2012::1
. 配置OSPFv3
ipv6 unicast-routing
router ospf 100
router-id 10.126.127.1
interface GigabitEthernet0/0
ipv6 ospf 100 area 0
interface GigabitEthernet0/1
ipv6 ospf 100 area 0
windows模块:
ip:
New-NetIPAddress -InterfaceAlias "网卡名字在ipconfig /all中找到所需要网卡" -IPAddress 192.168.10.254 -PrefixLength 24
dns:
Set-DnsClientServerAddress -InterfaceAlias "网卡名称" -ServerAddresses ("dns地址")
ip+gateway:
New-NetIPAddress -InterfaceAlias "Ethernet Instance 0 2" -IPAddress 202.96.128.1 -PrefixLength 24 -DefaultGateway 202.96.128.2
防火墙放行ping包:
netsh firewall set icmp 8 enable
建winrm组控:
winrm -help config中有下面的面板将local改为*
winrm set winrm/config/client @{TrustedHosts="*"}
在C:\Windows\System32\drivers\etc\hosts 中最后一行添加一条202.96.128.2 ct1其实就是将ct1跟地址绑定
allow server中添加dns server 搜ct1再添加凭据manage acc为ct1\administrator
linux模块:
#curl wget lynx nslookup dig ftp lftp showmount smbclient ssh telnet traceroute ntpdate lsof nmap mail host ipcalc
#!/bin/bash
hostname=$1
ip=$2
gw=$3
apt install -y curl wget lynx dnsutils ftp lftp nfs-common smbclient ssh telnet traceroute ntpdate lsof nmap mailutils host ipcalc vim bash-completion
hostnamectl set-hostname $stname
timedatectl set-timezone Asia/Shanghai
sed -i "s/debian/$stname/g" /etc/hosts
cat >>/etc/network/interfaces<<EOF
auto ens33
iface ens33 inet static
address 172.16.10.101/24
gateway 172.16.10.254
EOF
echo "PermitRootLogin yes" >> /etc/ssh/sshd_config
reboot
开启默认路由交换:
PermitRootLogin yes
iptables;
iptables -t nat -A POSTROUTING -s 172.16.10.0/24 -o ens33 -j MASQUERADE
dns安装:apt install -y bind9
apt install -y freeradius freeradius-mysql # 基础包和MySQL支持:ml-citation{ref="1,2" data="citationList"}
安装和配置Mariadb服务器:apt install mariadb-server
安装ca证书:apt install ca-certificates
安装OpenLDAP服务器:apt install slapd ldap-utils -y