1097 Deduplication on a Linked List(33行代码+超详细注释+测试点2分析)

分数 25

全屏浏览题目

作者 CHEN, Yue

单位 浙江大学

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 104, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

注意:测试点2是输入为-1 0的情况,此时应没有输出

注意:还有可能出现一些不在链表中的冗余数据

#include<bits/stdc++.h>
using namespace std;
const int N=100005;
map<int,int>mp;//记录key值是否出现过 
int main(){
    int data[N],next[N],res[N],remove[N];//data是某地址的数据,next下一个结点的地址,res是没有重复key的数组,remove是移除的链表 
    int first,n;
    cin>>first>>n;
    for(int i=0;i<n;i++){//输入链表 
        int add,k,ne;
        cin>>add>>k>>ne;
        data[add]=k;
        next[add]=ne;
    }
    int cur=0,cur2=0;//分别是res和remove当前的链表数 
    while(first!=-1){//不是最后一个结点 
        if(!mp[abs(data[first])]){//第一次出现的key 
            mp[abs(data[first])]=1;//置为1 
            res[cur++]=first;//将该地址放到res数组中 
        }
        else remove[cur2++]=first;//重复出现key值放到remove中 
        first=next[first];
    }
    if(cur){//res数组中有链表则输出 
        for(int i=0;i<cur-1;i++)printf("%05d %d %05d\n",res[i],data[res[i]],res[i+1]);
        printf("%05d %d -1\n",res[cur-1],data[res[cur-1]]);
    }
    if(cur2){//remove数组中有链表则输出
        for(int i=0;i<cur2-1;i++)printf("%05d %d %05d\n",remove[i],data[remove[i]],remove[i+1]);
        printf("%05d %d -1\n",remove[cur2-1],data[remove[cur2-1]]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值