1007 Maximum Subsequence Sum(最大连续子段和)

Given a sequence of K integers { N1​, N2​, ..., NK​ }. A continuous subsequence is defined to be { Ni​, Ni+1​, ..., Nj​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

代码长度限制        16 KB;时间限制        200 ms;内存限制        64 MB;

大意:

求出最大的子序列的和,以及该最大和序列的首尾元素。

分析:

利用num记录序列长度。关键点:当sum<0的时候,sum要清零,因为一个小于0的子序列对最大子序列和只有坏处,加上它只会减少。

代码:

#include<iostream> 
#include<stdio.h>  
#include<stdlib.h>
#include<math.h>   
#include<string.h>
#include<algorithm>
#include<map>
#include<unordered_map>
#include<vector>
#include<queue>
#include<stack>
#include<string>
#include<set>
using namespace std;   
int main(){
#ifdef ONLINE_JUDGE
#else    
    freopen("1.txt", "r", stdin);
#endif 
    //加入自己的代码
    int n;
    cin>>n;
    vector<int> v(n, 0), res(2, 0);
    int sum=0, max=-1, num=0;
    for(int i=0; i<n; i++){
        cin>>v[i];
        sum+=v[i];
        num++;//记录序列长度
        if(sum<0){
            sum=0;
            num=0;
        }else if(sum>max){//最开始这里写的if导致一直有测试点不过!!!
            max=sum;
//             cout<<"sum:"<<sum<<endl;
            res[0]=v[i-num+1];//+1,记得
            res[1]=v[i];
        }
    }
    if(max<0){
        cout<<0<<" "<<v[0]<<" "<<v[n-1];
    }else{
        cout<<max<<" "<<res[0]<<" "<<res[1];
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值