网络工程——专业实习训练(拓扑搭建3)

 配置命令

        1.实现全网互通

        2.配置静态路由

        3.创建地址池,下放地址

基础配置

AR1

interface GigabitEthernet0/0/0
 ip address 192.168.11.1 255.255.255.0
#
interface GigabitEthernet0/0/1
 ip address 192.168.13.1 255.255.255.0
#
interface GigabitEthernet0/0/2
 ip address 192.168.31.1 255.255.255.0
#
interface LoopBack0
 ip address 1.1.1.1 255.255.255.0
#
ospf 1 router-id 1.1.1.1
 area 0.0.0.1
  network 192.168.11.0 0.0.0.255
  network 192.168.13.0 0.0.0.255
  network 1.1.1.0 0.0.0.255
#
ip route-static 192.168.30.0 255.255.255.0 192.168.31.2 preference 160
ip route-static 192.168.40.0 255.255.255.0 192.168.31.2 preference 160

AR3

vlan batch 30 40
#
interface GigabitEthernet0/0/0
 ip address 192.168.13.2 255.255.255.0
#
interface GigabitEthernet0/0/1.30
 dot1q termination vid 10
 dot1q termination vid 30
 ip address 192.168.30.254 255.255.255.0
 arp broadcast enable
#
interface GigabitEthernet0/0/1.40
 dot1q termination vid 40
 ip address 192.168.40.254 255.255.255.0
 arp broadcast enable
#
interface GigabitEthernet0/0/2
 ip address 192.168.31.2 255.255.255.0
#
interface LoopBack0
 ip address 3.3.3.3 255.255.255.0
#
ospf 1 router-id 3.3.3.3
 import-route direct
 area 0.0.0.1
  network 192.168.13.0 0.0.0.255
  network 3.3.3.0 0.0.0.255
#
ip route-static 192.168.10.0 255.255.255.0 192.168.31.1
ip route-static 192.168.20.0 255.255.255.0 192.168.31.1

SW1

vlan batch 10 20
#
interface Vlanif1
 ip address 192.168.11.2 255.255.255.0
#
interface Vlanif10
 ip address 192.168.10.254 255.255.255.0
#
interface Vlanif20
 ip address 192.168.20.254 255.255.255.0
#
interface GigabitEthernet0/0/1
 port link-type access
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface GigabitEthernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface LoopBack0
 ip address 2.2.2.2 255.255.255.0
#
ospf 1 router-id 2.2.2.2
 area 0.0.0.0
  network 192.168.10.0 0.0.0.255
  network 192.168.20.0 0.0.0.255
 area 0.0.0.1
  network 2.2.2.0 0.0.0.255
  network 192.168.11.0 0.0.0.255

SW3

vlan batch 10 20
#
interface Ethernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface Ethernet0/0/3
 port link-type access
 port default vlan 10
#
interface Ethernet0/0/4
 port link-type access
 port default vlan 20
#
ospf 1
 area 0.0.0.0
  network 192.168.10.0 0.0.0.255
  network 192.168.20.0 0.0.0.255

SW4

vlan batch 10 20
#
interface Ethernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface Ethernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface Ethernet0/0/3
 port link-type access
 port default vlan 10
#
interface Ethernet0/0/4
 port link-type access
 port default vlan 20
#
ospf 1
 area 0.0.0.0
  network 192.168.10.0 0.0.0.255
  network 192.168.20.0 0.0.0.255

SW6

vlan batch 30 40
#
interface Ethernet0/0/1
 port link-type access
 port default vlan 30
#
interface Ethernet0/0/2
 port link-type access
 port default vlan 40
#
interface Ethernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 30 40

实验结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值