蓝桥杯-水域清理

 输入样例

2 3
2
1 1 1 3
1 2 2 2

输出样例

2

代码

import java.util.Scanner;

public class Main06 {
    public static void main(String[] args) {
        Scanner scan = new Scanner(System.in);
        int n = scan.nextInt();     //行
        int m = scan.nextInt();     //列
        int t = scan.nextInt();     //次数
        int count = 0;
        int[][] arr = new int[n][m];
        for (int i = 0; i < n; i++) {
            for (int j = 0; j < m; j++) {
                arr[i][j] = -1;     //水域全部赋值为-1
            }
        }
        for (int i = 0; i < t; i++) {
            int r1 = scan.nextInt();
            int c1 = scan.nextInt();
            int r2 = scan.nextInt();
            int c2 = scan.nextInt();
            for (int j = r1 - 1; j <= r2 - 1; j++) {
                for (int k = c1 - 1; k <= c2 - 1; k++) {
                    arr[j][k] = 1;      //如果清理就变为1
                }
            }
        }
        for (int i = 0; i < n; i++) {
            for (int j = 0; j < m; j++) {
                if (arr[i][j] == -1) {
                    count++;        //统计未清理面积
                }
            }
        }
        System.out.println(count);
    }
}

  • 21
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值