ACM PKU 1003--Hangover

以下是该题的描述(http://poj.org/problem?id=1003

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.

Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00

3.71

0.04

5.19

0.00

Sample Output

3 card(s)

61 card(s)

1 card(s)

273 card(s)

这道题要求你编写一个程序,接受一系列的输入,每个输入是一个正的浮点数,表示卡片的总长度。然后,程序需要计算出最少需要多少张卡片才能使得卡片的总长度达到输入的长度。

具体来说,第一张卡片可以最大倾斜长度为 1/2 个卡片长度,第二张卡片可以最大倾斜长度为 1/3 个卡片长度,第三张卡片可以最大倾斜长度为 1/4 个卡片长度,以此类推。

程序需要输出最少需要的卡片数量,每个输入数据后面需要输出一个单位 card(s) 。直到输入 0.00 结束输入。

以下为解决该问题的一种解法

思路是这样的:可以使用一个 while 循环来迭代处理多组数据,并使用一个变量来存储当前卡片的总长度,以及另一个变量来记录卡片的数量。在每次迭代中,将当前卡片的总长度加上 1/(n+1),其中 n 是当前卡片的数量。当卡片总长度大于等于输入的长度时,输出当前卡片的数量,并重置卡片总长度和数量。

#include <iostream>
using namespace std;
int main() {
    double c;
    while (cin >> c && c != 0.00) {
        int n = 0;
        double len = 0;
        while (len < c) {
            n++;
            len += 1.0 / (n + 1);
        }
        cout << n << " card(s)" << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值