【编程实现】
做统计。
输入10个正整数,以空格分隔。依次输出其中的最大值、最小值以及平均 值,以逗号分隔。
输入描述:输入10正整数(0<正整数≤1000) ,正整数之间空格隔开。
输出描述: 一行输出10个正整数中的最大值、最小值及10个数的平均值 (平均值保留两位小数),三个值之间一个英文逗号隔开。
【样例输入】
12345678910
【样例输出】
10,1,5.50
【编程实现】
#include<bits/stdc++.h>
using namespace std;
int main(){
int min,max,sum=0,temp; //定义最小min,最大max,累加sum,临时temp
cin>>temp; //输入临时变量1
sum=min=max=temp; //将临时变量赋值
for(int i=0;i<9;i++){//循环
cin>>temp;//循环输入之后的变量
min=min<temp?min:temp;//变量进行对比将最小赋值min
max=max>temp?max:temp;//变量进行对比将最大赋值max
sum+=temp;//累加
}
cout<<max<<","<<min<<","; //输出最大和最小
printf("%.2f",sum/10.0); //输出平均值,案例要求小数点后两位
return 0;
}
#include<bits/stdc++.h>
using namespace std;
int main(){
int min,max,sum=0,temp;
cin>>temp;
sum=min=max=temp;
for(int i=0;i<9;i++){
cin>>temp;
min=min<temp?min:temp;
max=max>temp?max:temp;
sum+=temp;
}
cout<<max<<","<<min<<",";
printf("%.2f",sum/10.0);
return 0;
}
#include<bits/stdc++.h>
using namespace std;
int main(){
int min,max,sum=0,temp;
cin>>temp;
sum=min=max=temp;
for(int i=0;i<9;i++){
cin>>temp;
min=min<temp?min:temp;
max=max>temp?max:temp;
sum+=temp;
}
cout<<max<<","<<min<<",";
printf("%.2f",sum/10.0);
return 0;
}