19-CodeForces-58A-ChatRoom

Chat room

题面翻译

给定一个字符串使删除这个字符串的一些字符使它变成“hello”

题目描述

Vasya has recently learned to type and log on to the Internet. He immediately entered a chat room and decided to say hello to everybody. Vasya typed the word $ s $ . It is considered that Vasya managed to say hello if several letters can be deleted from the typed word so that it resulted in the word “hello”. For example, if Vasya types the word “ahhellllloou”, it will be considered that he said hello, and if he types “hlelo”, it will be considered that Vasya got misunderstood and he didn’t manage to say hello. Determine whether Vasya managed to say hello by the given word $ s $ .

输入格式

The first and only line contains the word $ s $ , which Vasya typed. This word consisits of small Latin letters, its length is no less that 1 and no more than 100 letters.

输出格式

If Vasya managed to say hello, print “YES”, otherwise print “NO”.

样例 #1

样例输入 #1

ahhellllloou

样例输出 #1

YES

样例 #2

样例输入 #2

hlelo

样例输出 #2

NO

代码

小白的码

// 58A Chat room

/**
 * CodeForces->力扣->洛谷->牛客->CodeForces
 * 竞赛6P <训练>
 * CodeForces+力扣+牛客+洛谷+ZZULIOJ+等等+CodeForces <比赛>
 * 
 * 专注*行动*坚持*争分夺秒 <=> 算法竞赛金牌!!!
 * 
 * 一心一意,10000小时,每天10小时+,两年九个月
*/

// 算法竞赛入门经典系列源码解析
    // 算法竞赛入门经典第2版 P
    // 算法竞赛入门经典 习题与解答 P
    // 算法竞赛入门经典 训练指南 P
    // 算法竞赛入门经典 算法实现 P
// 程序设计竞赛训练营
    // 基础与数学概念 P
    // 算法与实践 P
// 牛客练习
// 洛谷练习 
// 力扣练习 
// CodeForces 58A Chat room

/*
    Dreams never shine!
    It's you that shine while chasing your dreams :)
    JAYO!!
*/

#include <iostream>
#include <algorithm>
#include <string>
#include <typeinfo.h>

using namespace std;

int main() {
   
    string line;
    cin >> line;
    string hi = "hello";
    int i = 0;
    int index = -1;

    for ( ; i < hi.size(); ) {
   
        // cout << hi.substr(i, 1) << endl;
        // cout << index << endl;
        // cout << line.find(hi.substr(i, 1), index + 1) << endl;




        int pos = line.find(hi.substr(i, 1), index + 1);
        // 不能用auto,auto会让pos成为无符号数,
        // 当pos和-1比较时,index会被转换为无符号,-1会变成一个很大的数
        // auto pos = line.find(hi.substr(i, 1), index + 1);

        // cout << typeid(pos).name() << endl;
        if 
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值