[山东科技大学OJ]2676 Problem G: 数字统计二

 

Time Limit: 1 Sec Memory Limit: 128 MB

Submit: 331 Solved: 145

[Submit][Status]

Description

给出一些数字,统计出现最多的数字0~9的次数

 

Input

输入为多行(1~500000行),至EOF结束。每行包含一个数字k,0<=k<=200000

 

Output

输出出现次数最多的数字0~9的个数。

 

Sample Input

12

11

10

9

8

7

6

5

4

3

2

Sample Output

4

HINT

Append Code

[Submit][Status]


#include <stdio.h>

#include <stdlib.h>

#include <string.h>

int main()

{

    char a[500001];

    int b[10]={0};

    while(scanf("%s",a)!=EOF)

    {

        for(int i=0;i<strlen(a);i++)

            b[a[i]-'0']++;

    }

    int max=b[0];

    for(int i=0;i<10;i++)

        if(b[i]>max)

        max=b[i];

    printf("%d",max);

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值