末尾添加新的结点

文章描述了一个编程问题,要求创建一个用于存储学生信息的单向链表,并实现`create`和`insertdata`函数。`create`函数接收用户输入的一系列整数,创建链表;`insertdata`函数在链表末尾插入新的学生信息。测试程序展示了如何使用这些函数并给出了输入输出样例。
摘要由CSDN通过智能技术生成

本题要求实现,将输入的学生信息组成单向链表;并在末尾追加一学生信息。

函数接口定义:

struct stud_node *create();
struct stud_node *insertdata( struct stud_node *head, int n,char name[],int s );

函数create利用scanf从输入中获取一系列正整数,当读到0时表示输入结束。

裁判测试程序样例:

解释

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define LEN sizeof(struct stud_node)

struct stud_node {
     int    num;
     char   name[20];
     int    score;
     struct stud_node *next;
};

struct stud_node *create();
struct stud_node *insertdata( struct stud_node *head, int n,char name[],int s );

int main()
{
    int  num,score;
    char name[20];
     struct stud_node *p, *head = NULL;
     head = create();
     scanf("%d%s%d",&num,name,&score);
      head=insertdata(head,num,name,score);
     for ( p = head; p != NULL; p = p->next )
        printf("%d %s %d\n", p->num, p->name, p->score);
    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例1:

解释

10001 zhang 96 10002 wang 63 0 10003 liu 100

输出样例1:

10001 zhang 96
10002 wang 63
10003 liu 100

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

struct stud_node *create()
{
    struct stud_node *p2,*p1,*head;
    head=NULL;
    int n=0;
    p1=p2=(struct stud_node*)malloc(sizeof(struct stud_node));
    scanf("%d",&p1->num);
    while(p1->num!=0)
    {
        scanf("%s %d",p1->name,&p1->score);
        n=n+1;
        if(n==1)
            head=p1;
        else
            p2->next=p1;
        p2=p1;
        p1=(struct stud_node*)malloc(sizeof(struct stud_node));
        scanf("%d",&p1->num);   
    }
    p2->next=NULL;
    return(head);
}
struct stud_node *insertdata( struct stud_node *head, int n,char name[],int s )
{
    struct stud_node *p=head,*pr=head,*q=head;
    p=(struct stud_node*)malloc(sizeof(struct stud_node));
    p->next=NULL;
    p->num=n;
    strcpy(p->name,name);
    p->score=s;
    while(pr->num<n&&pr->next!=NULL)
    {
        q=pr;
        pr=pr->next;
    }
    pr->next=p;
    return(head);
}

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值