题目:
给定任一个各位数字不完全相同的 4 位正整数,如果我们先把 4 个数字按非递增排序,再按非递减排序,然后用第 1 个数字减第 2 个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的 6174
,这个神奇的数字也叫 Kaprekar 常数。
例如,我们从6767
开始,将得到
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...
现给定任意 4 位正整数,请编写程序演示到达黑洞的过程。
输入格式:
输入给出一个 (0,104) 区间内的正整数 N。
输出格式:
如果 N 的 4 位数字全相等,则在一行内输出 N - N = 0000
;否则将计算的每一步在一行内输出,直到 6174
作为差出现,输出格式见样例。注意每个数字按 4
位数格式输出。
输入样例 1:
6767
输出样例 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
输入样例 2:
2222
输出样例 2:
2222 - 2222 = 0000
代码:
#include <iostream>
#include <vector>
#include <algorithm>
#include <string>
using namespace std;
vector<int>todigits(int num) { //将数字放在容器里储存起来(类似数字转数组)
vector<int>digits;
while (num > 0) {
digits.push_back(num % 10);
num /= 10;
}
return digits;
}
int tonumber(vector<int>digits) { //将容器里的数转换为数字(类似数组转数字)
int num = 0;
for (int i = 0; i < digits.size(); i++) {
num = num * 10 + digits[i];
}
return num;
}
bool equal(int num) {
int first = num / 1000;
int second = num / 100 % 10;
int third = num / 10 % 10;
int fourth = num % 10;
return (first == second) && (second == third) && (third == fourth);
}
int main() {
int num;
cin >> num;
int result = 0;
if (!equal(num)) {
while (result != 6174) {
vector<int>digit = todigits(num);
sort(digit.begin(), digit.end(), greater<int>());
int num1 = tonumber(digit);
sort(digit.begin(), digit.end());
int num2 = tonumber(digit);
result = num1 - num2;
num = result;
string st = to_string(num2);
switch (st.length()) {
case 4:cout << num1 << " - " << num2 << " = " << result << endl;
break;
case 3:cout << num1 << " - " << "0" << num2 << " = " << result << endl;
break;
case 2:cout << num1 << " - " << "00" << num2 << " = " << result << endl;
break;
case 1:cout << num1 << " - " << "000" << num2 << " = " << result << endl;
break;
}
}
}
else cout << num << " - " << num << " = " << "0000";
return 0;
}
这是我写的代码,呵呵,肯定是不对的。我也感到很无语,答案正确了,运行超时了,20分只得了14分。 可是我又不想改,也不知道怎么改才能减少运行时间。
下面的代码用了cstdio头文件中的sscanf函数和sprintf函数,其中sscanf函数是将把字符数组str以"%d"的格式输入n中,sprintf函数是将把整数n格式化为一个四位数,再以“%d”的格式写到字符数组中。在里面的代码中,我使用了string头文件下的stoi函数替代了sscanf函数。
代码:
#include <cstdio>
#include <algorithm>
#include <string>
using namespace std;
bool cmp1(char a, char b) //用bool函数进行数组(字符串)升序降序变化真的很好用,配合上sort函数
{
return a < b;
}
bool cmp2(char a, char b)
{
return a > b;
}
int main()
{
int n, a, b;
char str[6];
while (~scanf("%d", &n))
{
sprintf(str, "%04d", n); //把整数n格式化为一个四位数,再以“%d”的格式写到字符数组中
do {
sort(str, str + 4, cmp2); //非递减排序
//sscanf(str, "%d", &a); //把字符数组str以"%d"的格式输入n中
a = stoi(str);
printf("%s - ", str);
sort(str, str + 4, cmp1); //非递增排序
printf("%s = ", str);
//sscanf(str, "%d", &b);
b = stoi(str);
sprintf(str, "%04d", a - b);
printf("%s\n", str);
} while (a - b != 6174 && a - b != 0);
}
return 0;
}